No announcement yet.
  • Filter
  • Time
Clear All
new posts

  • IE script warning error while loading large files (20000 rows) in List Grid


    While loading the file with more than 20,000 rows in List Grid, we are getting the below IE warning message.

    "Stop running this script?
    A script on this page is causing IE to run slowly. If it continues to run, your computer may become unresponsive."

    IE version = 8.0
    Smart GWT = 2.5
    GWT = 2.0.4

    Number of columns in grid = 25

    Any suggestions to resolve this issue. Any upgraded version of GWT or SMart GWT has any solution for this issue. Please suggest.
    Attached Files
    Last edited by chadhim; 18th Apr 2012, 02:46.

  • #2
    I have not noticed this in smart gwt 3.0.

    Are you sure your "FetchMode" is set correctly. Lookup resultset.setFetchMode(FetcHmode.Local vs Paged). So that you are only bringing back a couple hundred of the rows, not all of them?

    I might also try just making a simple grid somewhere in your application, and binding it to your data source, with just the default settings. And see if that has the same problem. Then add in one by one your settings to see where you got into trouble.

    Just a thought, good luck!!! PS I don't work for Isomorphic :-)



    • #3
      Make sure you are using data paging and incremental rendering. Both are on by default, but you could have disabled them by settings such as showAllRecords:true. Once you are correctly configured even IE8 handles millions of records


      • #4
        An issue has just been corrected where if you scrolled to the bottom of a large grid and interacted with rows / cells, in IE8 and earlier you could get intermittent "script running slowly" warning dialogs.

        This fix is in tomorrow's 3.0p and 3.1d builds (and didn't apply before that - the problem was introduced with the feature of marking records for removal).