Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • #31
    Hi Isomorphic,

    it's now working in all browsers (tested Win8.1 with IE11 FF26 GC44) with v10.0p_2015-08-18/PowerEdition Deployment.

    Thank you & Best regards
    Blama

    Comment


    • #32
      Hi Isomorphic,

      Originally posted by Isomorphic View Post
      If you have fixed height recordComponents - yes we'd recommend you setRecordComponentHeight() so the grid knows how tall rows will render.
      With respect to the source of this sample, where you set virtualScrolling: false, do you suggest using setRecordComponentHeight() or virtualScrolling: false, if I have buttons lower than the normal row height just as in the linked sample?
      I assume virtualScrolling: false, but I'm not sure.

      Best regards
      Blama

      Comment


      • #33
        There is a slight clarity advantage to setting recordComponentHeight instead of virtualScrolling:false, since setting virtualScrolling:false would disable virtual scrolling even if it is needed for a purpose *other than* record components.

        Comment


        • #34
          Hi Isomorphic,

          I tested the default behavior a bit: In the sample (now on v11.0p_2017-05-07),
          Code:
          virtualScrolling:false
          is needed whether you set
          Code:
          recordComponentHeight: 22
          or not.
          Without it, virtualScrolling it always enabled.

          This is in sync with the docs.
          I assume that for a use case like in the sample you suggest setting
          Code:
          virtualScrolling:false,
          recordComponentHeight: 22 // (where 22 is the max height of the possible recordComponents)
          don't you?

          Best regards
          Blama

          Comment


          • #35
            That particular sample happened to have few enough records that the whole dataset could be rendered at once, so you wouldn't see the open space at the end, so the virtualScrolling:false setting has no visible effect until there are more records.

            But yes, if you are going to disable virtual scrolling with recordComponents, you do need to set recordComponentHeight, and you need to ensure you aren't using any other features that would normally turn on virtual scrolling (as listed in the docs).

            Comment

            Working...
            X