No announcement yet.
  • Filter
  • Time
Clear All
new posts

  • new smartclient visual builder datasource editor bug

    There seems to be a problem with DataSource editing in the newer 8.0 SC EVAL nightly builds, as recent as 2011-01-06

    Opening the datasource editor in Visual Builder fails.

    Steps to reproduce:

    1) unzip the SC archive, launch start_embedded_server.bat, open the web browser to localhost:8080, go into tools/Visual builder.

    2) select a datasource like "countryDS" from the DataSources window, and click Edit.

    I get a dialog that says "loading datasource 'CountryDS'" and the shaded gradient portion at the bottom of what should be the datasource editor window. It then gets stuck this way until I reload the whole thing.

    (I'd attach a screenshot, but I don't see a way to do that in this forum)

    Doesn't seem to matter which dataset I choose. The server log messages printed after I click the edit button are below, but don't seem especially informative.

    A similar problem happens when you try to create a new datasource.

    I've tried Firefox (3.6.13), IE (8), Chrome and the result is always the same. This is using Windows 7 as the host with JRE 1.6.0_23

    I also installed a version on linux with a slightly older JRE and ran the server there, but ran the same browsers back on my desktop. Same results.

    I recalled that this feature worked when I tested it during my first pass evals a few weeks ago. (This product is now in the shortlist of things that I'm trying more in-depth experiments on).

    I went back and downloaded the version dated 2010-12-22 and this feature works fine. So, somewhere along the way this bug was introduced.

    === 2011-01-06 15:27:29,080 [sor6] INFO  RequestContext - URL: '/tools/visualBuilder/vbOperations.jsp', User-Agent: 'Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)': Moz (Gecko) with Accept-Encoding header
    === 2011-01-06 15:27:29,095 [sor6] DEBUG XML - Parsed XML from (in memory stream): 0ms
    === 2011-01-06 15:27:29,095 [sor6] DEBUG RPCManager - Processing 1 requests.
    === 2011-01-06 15:27:29,111 [sor6] DEBUG RPCManager - Request #1 (DSRequest) payload: {
    === 2011-01-06 15:27:29,142 [sor6] DEBUG AppBase - [builtinApplication.countryDS_loadSchema] No userTypes defined, allowing anyone access to all operations for this application
    === 2011-01-06 15:27:29,142 [sor6] DEBUG AppBase - [builtinApplication.countryDS_loadSchema] No public zero-argument method named '_countryDS_loadSchema' found, performing generic datasource operation
    === 2011-01-06 15:27:29,142 [sor6] INFO  DSResponse - [builtinApplication.countryDS_loadSchema] DSResponse: List with 1 items
    === 2011-01-06 15:27:29,158 [sor6] DEBUG RPCManager - Content type for RPC transaction: text/plain; charset=UTF-8
    === 2011-01-06 15:27:29,174 [sor6] DEBUG RPCManager - non-DMI response, dropExtraFields: false
    === 2011-01-06 15:27:29,174 [sor6] INFO  Compression - /tools/visualBuilder/vbOperations.jsp: 2147 -> 587 bytes

  • #2
    Hi Wojtow,
    Thanks for the report. This was a last minute bug that made it into the 8.0 release.
    We've already posted a patch for this issue here. You can fix this issue in the 8.0 build by applying the patch code from that thread to the 'index.jsp' file (under the smartClientSDK/tools/visualBuilder/ directory) - add it to the script block directly after isomorphic:loadISC jsp tag.

    The issue has been fixed internally as well - the fix will be in our next nightly build.