No announcement yet.
  • Filter
  • Time
Clear All
new posts

    admin console is hanging

    I deployed smart client in Weblogic 9.2 environment. I am using Oracle 9.1 database. Browser is IE6 with SP2. When I click on Database tab it is hanging. I have message on my screen "Please wait - getting list and status of configured databases".
    It works fine when I am running embedded tomcat provided with your installation.
    I develop example app on Weblogic 9.2 to integrate with server using DMI and populating VOs from the same Oracle database and it works fine.
    My WEB-INF\classes\ is provided
    I tried this
    webRoot: __AUTODETECT__
    isomorphicPathRootRelative: isomorphic
    project.datasources: $webRoot/shared/ds
    project.ui: $webRoot/shared/ui
    project.apps: $webRoot/shared/app

    Also I tried this
    webRoot: __AUTODETECT__
    isomorphicPathRootRelative: isomorphic
    project.datasources: $webRoot/shared/ds
    project.ui: $webRoot/shared/ui
    project.apps: $webRoot/shared/app
    sql.defaultDatabase: Oracle
    sql.Oracle.driver.serverName: 192.*.*.* * in real file are actual ip
    sql.Oracle.driver.portNumber: 1521
    sql.Oracle.driver.databaseName: my SID
    sql.Oracle.driver.user: my user
    sql.Oracle.driver.password: my password
    What am I missing?


    Hi David,

    To clarify - with SmartClient deployed on Weblogic 9.2 you are able to access the Oracle database from an application, but you are not able to use the Databases tab?

    If you have followed the Deploying SmartClient instructions, it is expected that the Databases tab would not be functional, as this functionality should normally be disabled for production deployment to prevent end users from toying with database settings.

    However, it should be giving a clear error. We'll check on this.

    If you do actually want to enable database access in production, see the file mentioned in the Deploying SmartClient instructions.


      Thank you for promp response.
      That is correct I am able to access the Oracle database from an application, but I am not able to use the Databases tab. I am running Weblogic on my local dev machine and it would be nice to be able to connect to database from there using Database tab to do prototyping.
      Following "Deploying smart client" instructions to enable admin console I put the following libraries in WEB-INF\lib
      I copied db directory from smartclientSDK\WEB-INF to my WEB-INF directory on weblogic.
      I copied smartclientSDK\WEB-INF\classes\ to my WEB-INF\classes\
      I copied tools dir from smartclientSDK\tools to my webroot\tools

      I rebooted the server.
      Still the same clicking on "Databases tab" hangs.
      Could you please advise if I am missing any required steps.



        I accessed console though URL directly http://localhost:7001/URProcessManagement/tools/adminConsole.jsp
        I get the same hanging message as when I click on it from "Database tab"and in addition I see error in the server log (no error in server log when clicking on Database tab)

        Maybe it will help.


        === 2007-10-02 15:52:05,496 [ng)'] DEBUG RPCManager - Processing 2 requests.
        === 2007-10-02 15:52:05,496 [ng)'] INFO AppBase - Using class 'com.isomorphic.t
        ools.AdminConsole' as the implementer for application 'adminConsole'
        === 2007-10-02 15:52:05,512 [ng)'] ERROR IDACall - Top-level servlet error:
        java.lang.Exception: Unable to instantiate - c
        heck the appImplementer setting in the app file for appID: adminConsole and ensu
        re that your class has a public zero-argument constructor - actual error was: ja
        at com.isomorphic.application.AppBase.findByAppID(
        at com.isomorphic.datasource.DSRequest.getApp(
        at com.isomorphic.datasource.DSRequest.<init>(
        at com.isomorphic.rpc.RPCManager.parseRequest(
        at com.isomorphic.rpc.RPCManager.<init>(
        at com.isomorphic.servlet.IDACall.processRequest(
        at com.isomorphic.servlet.IDACall.doPost(
        at javax.servlet.http.HttpServlet.service(


          Hi David,

          That explains it - you need isomorphic_tools.jar and its dependencies as listed in the Deployment Instructions.

          However, you do have kind of a weird hybrid here. Generally a tool like the Admin Console is just used within the embedded Tomcat environment, along with rthe documentation, examples, Visual Builder and other tools. Materials from the isomorphicSDK are not usually installed into the target deployment environment because they should not be there in production, and removing them during the packaging of the final application complicates deployment steps. However, if this works for you, go for it :)