No announcement yet.
  • Filter
  • Time
Clear All
new posts

    AnimateShowEffect and setEndsAt( - ) method

    Have been running smartGWT 6.1 for a long while. Today I thought it was time to explore smartGWT 12.0p. Using overnight build of 2018-11-30 of 12.0p,

    Got this compile error on my working 6.1 code:

    :1408: error: cannot find symbol
    [javac] showEffect.setEndsAt("L");
    [javac] ^
    [javac] symbol: method setEndsAt(String)
    [javac] location: variable showEffect of type AnimateShowEffect

    A simple fix is to change to the latest method naming: setEndAt( - ).

    final AnimateShowEffect showEffect = new AnimateShowEffect();

    But is this change permanent or something I just happened across in version 2018-11-30 ?

    Of course this happens to be shared code among many projects, so I can't now transition just one project to 12.0p. It seems like I have to transition all the projects that reference the code. Ugg...

    In C/C++ I would use the pre-compiler to work around this. Any suggestions?
    Last edited by Isomorphic; 5th Dec 2018, 13:35.

    The old API was apparently wrongly named and would've had no impact as it set the wrong JS property. The actual property name that needs to be set is "endAt" - that should be permanent.



      But why not continue having a deprecated setEndsAt() method, rather than removing it all together? Now all projects must move to the new smartGWT 12.0 libs , which is a major effort for our developers.

      I suppose we could handle this lib incompatibility in two steps. Remove the setEndsAt("L") call in our sources and allow 6.1 lib compiles. Then when ALL projects are at 12.0 and above, add back the setEndAt("L") call. Think this fix of yours is has a bigger impact on users than you may have considered. FYI
      Last edited by tece321; 4th Dec 2018, 07:43.


        How do I correct the mistyping in the title of this thread? i.e. change AnimaeShowEffect to AnimateShowEffect. :eek:


          We've committed a fix to SGWT 5.1p/SC 10.1p and newer branches to ensure that compilation doesn't break and that the setting applied to "endsAt" is picked up even though the property was misnamed. This should be in the next nightly builds, dated 2018-12-11.

          Originally posted by tece321 View Post
          How do I correct the mistyping in the title of this thread? i.e. change AnimaeShowEffect to AnimateShowEffect. :eek:
          The irony of a misnamed thread about a misnamed property is not lost on us. :) We've corrected the title.