No announcement yet.
  • Filter
  • Time
Clear All
new posts

    Migrate SmartGWT 4.0 sample project (BuiltinDs) to Maven

    I am currently trying to migrate smartGWT 4.0 sample project callled BuiltinDS to Maven through Eclipse, with the following characteristics:
    • Smartgwt version 4.0-pro
    • GWT version 2.8.1
    • JDK java 1.8
    • Eclipse version 2021-03
    • SmartGWT libraries are in NEXUS



    The compilation is successful, but when I run a configuration of type GWT Development Mode (CodeServer) the console gives me the following and the application does not launch.

    Attached Files

    Your code server appears to be at port 9876, but you are accessing 8888.


      Thanks. I already changed the port. Now there seems to be a connection but the data is not displayed Click image for larger version

Name:	MicrosoftTeams-image (27).png
Views:	193
Size:	12.2 KB
ID:	267765Click image for larger version

Name:	MicrosoftTeams-image (28).png
Views:	188
Size:	42.8 KB
ID:	267766


        Please see the Debugging and SuperDevMode overviews in reference. There is extensive information about troubleshooting.


          Thanks for the suggestion. I was reviewing the documentation and this part that is shown in the image is not working for me.

          Click image for larger version

Name:	imagen1.png
Views:	292
Size:	46.1 KB
ID:	267841

          When I try to access the URL: I get the following message:

          Click image for larger version  Name:	MicrosoftTeams-image (29).png Views:	0 Size:	35.0 KB ID:	267839

          and in console I get the following:

          Click image for larger version

Name:	MicrosoftTeams-image (30).png
Views:	290
Size:	47.0 KB
ID:	267842

          I think it is an error in my BuiltInDS.html file, which I already attached in my first comment

          Note: port 60544 is a random port that is not in use fr another application or service.
          Last edited by norida.olivera; 7 Apr 2022, 06:12.


            First I tried to do the creation of the sample environment (BuiltInDs) with the archetypes described here using archetype-smartgwt-example-builtinds in the mvn command, but it didn't work... those archetypes seem to be deprecated.

            Then, I tried another approach by creating a maven project from Eclipse, looking for the SmartGWT archetypes and finally, I was able to create and run the SmartGWT sample project (which includes basic graphical elements like buttons, etc.) with the following characteristics:
            • SmartGWTversion 6.1-p20200412
            • GWT version 2.8.0
            • JDK java 1.8.0_241
            • Apache Maven 3.6.3
            • Eclipse version 2021-03
            This is how the project structure looks like.

            Click image for larger version

Name:	14-07-2022_17-17-51.png
Views:	132
Size:	45.7 KB
ID:	268328

            In order to run the project I use these two configurations:

            Click image for larger version  Name:	14-07-2022_14-56-29.png Views:	0 Size:	73.9 KB ID:	268316

            Click image for larger version  Name:	14-07-2022_14-57-23.png Views:	0 Size:	63.9 KB ID:	268317

            Also, I attached the files I used in my project:


            With the environment already configured, I wanted to add the Datasources following these and these indications. The execution of both Run_basicenv and Debug_BasicEnv configurations was successful, but it didn't show the information of the datasource file (bufferTable.ds.xml).

            Click image for larger version  Name:	14-07-2022_15-10-01.png Views:	0 Size:	16.8 KB ID:	268326

            After that, I tried to check the data source using the Visual Builder tool but I get this error message (see the detail in Error.txt file) :


            Click image for larger version  Name:	14-07-2022_17-50-20.png Views:	0 Size:	86.5 KB ID:	268318

            Currently I can only access that version of SmartGWT, so it would be very helpful if you could help me figure out what settings or dependencies I might be missing.

            Thank you very much in advance.

            Attached Files
            Last edited by norida.olivera; 15 Jul 2022, 13:32.


              4.0 is over 9 years old and well past end-of-life - even later versions are already end-of-lifed (see So, it looks like you are trying to use the latest Maven plugin with an end-of-lifed version - this would not be expected to work, and we're surprised it did at all.

              We're also not sure why you're looking at Google App Engine (??) and there would be no reason to try to use Visual Builder to verify a DataSource.

              If you are planning to upgrade but haven't purchased the new license yet, use the Evaluation Edition for now - sorry but, for obvious reasons, we won't look into problems reported with end-of-lifed products (that's what end-of-lifed means!).