Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

    iPad Pro problem

    SNAPSHOT_v13.1d_2024-05-16/AllModules Development Only

    Safari on:
    iPad Simulator, 10th generation, iPadOS 17.4
    iPad Pro Simulator, 11" 4th generation, iPadOS 17.4
    iPad Pro physical device, 11" 2nd generation, iPadOS 17.4.1

    Hello, if you try the test case showcaseApp, when you run it in portrait mode, you'll see that something isn't right:

    Click image for larger version

Name:	Simulator Screenshot - iPad Pro (11-inch) (4th generation) - 2024-05-17 at 10.57.30.png
Views:	118
Size:	108.7 KB
ID:	272376

    then if you rotate the device, it's fine:

    Click image for larger version

Name:	Simulator Screenshot - iPad Pro (11-inch) (4th generation) - 2024-05-17 at 10.58.06.png
Views:	110
Size:	162.2 KB
ID:	272377

    but if you rotate it again in portrait:

    Click image for larger version

Name:	Simulator Screenshot - iPad Pro (11-inch) (4th generation) - 2024-05-17 at 10.58.21.png
Views:	115
Size:	154.3 KB
ID:	272378

    you'll see that fonts and controls have shrunk.

    Attached Files

    #2
    In that first screenshot, what do you have in mind with "something isn't right"? The portrait display of for tablet mode in a SplitPane is intended to show the details of the selected item. With no selected item, this is going to be blank. You can press the "Categories" link in the upper left to get back to the Categories and select something.

    Separately, you previously reported a bizarre font-shrinking problem that happened only when the browser's developer tools were opened (and possibly only in Chrome) and seemed to be related to a Chrome bug where they erroneously try not to load fonts that aren't immediately used. Is this the same problem, with the same situation where it can be triggered? If not, please let us know if you can get it to happen in a true simulator (not the browser's simulators, which are extremely dubious) or on the true device.

    Comment


      #3
      Hello, first of all, sorry for posting in the wrong forum, actually I'm having this problem with SmartClient (both in the showcase and in my app).


      Originally posted by Isomorphic View Post
      In that first screenshot, what do you have in mind with "something isn't right"? The portrait display of for tablet mode in a SplitPane is intended to show the details of the selected item. With no selected item, this is going to be blank. You can press the "Categories" link in the upper left to get back to the Categories and select something.
      thanks fot the heads up, I didn't realize that.
      Originally posted by Isomorphic View Post
      Separately, you previously reported a bizarre font-shrinking problem that happened only when the browser's developer tools were opened (and possibly only in Chrome) and seemed to be related to a Chrome bug where they erroneously try not to load fonts that aren't immediately used. Is this the same problem, with the same situation where it can be triggered? If not, please let us know if you can get it to happen in a true simulator (not the browser's simulators, which are extremely dubious) or on the true device.
      Nope, this isn't related to that problem. I don't see errors nor js warnings.

      But note that I'm not seeing this in the browser simulator. I'm actually seeing this in a true device, and in true simulators (on my Macbook Pro with Sonoma 14.4.1).
      The physical device is:
      iPad Pro 11" 2nd generation, iPadOS 17.4.1

      and then I've tried a couple of simulators:
      iPad Simulator, 10th generation, iPadOS 17.4
      iPad Pro Simulator, 11" 4th generation, iPadOS 17.4

      I may try others if can be useful.

      Note that I've also tried an Android tablet, and there isn't the shrinking problem.

      Comment


        #4
        We've reproduced this issue on iOS and are looking into possible solutions.

        Comment


          #5
          This should be addressed by nightly builds dated 2024-06-16 and beyond for SC/SGWT 13.x.

          Comment


            #6
            I can confirm it's fixed, thank you very much

            Comment

            Working...
            X