Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • error start smartclient : start_embedded_server.bat

    I already having SmartClient_81_PowerEdition and it is running fine.

    I downloaded SmartClient_v120p_2018-10-14_Evaluation, and when starting "start_embedded_server.bat , I am getting a java error as below:

    Using user-defined JAVA_HOME: "C:\Program Files\Java\jdk1.6.0_22"

    Active code page: 65001
    Picked up _JAVA_OPTIONS: -Xmx512M
    Exception in thread "main" java.lang.UnsupportedClassVersionError: com/isomorphi
    c/embedded_tomcat/EmbeddedTomcat85 : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:632)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:616)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
    1)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
    Could not find the main class: com.isomorphic.embedded_tomcat.EmbeddedTomcat85.
    Program will exit.
    Active code page: 437


    Please advice.
    Regards,
    Fuad


  • #2
    12.0 and higher now require JDK 1.7 or higher.

    Comment

    Working...
    X