Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • jerickson
    replied
    Thanks!

    Leave a comment:


  • Isomorphic
    replied
    Don’t quote Boolean values, you are passing Strings instead of actual Booleans.

    See also checkBoxItem.labelAsTitle got info on how CheckBoxItem occupies columns and what to set.

    Leave a comment:


  • Blama
    replied
    If the problem is screen real estate and the Form will only include Checkboxes, you could play with colWidths/titleWidth.

    Best regards,
    Blama

    Leave a comment:


  • How to show a CheckBox in the first column of a DynamicForm

    I have a form consisting of 4 fields -- all of which will be displayed as checkboxes. As such, I would like the checkboxes to be aligned in the first column with the title/label to the right of the box as it is displayed by default. I am having trouble moving the checkbox to the first column, which I guess is normally "reserved" for the FormItem's title.

    Here is my latest crack at the for properties:

    filterFormDefaults: {
    _constructor: isc.DynamicForm,
    autoParent: "panelCanvas",
    width: "100%",
    margin: 5,
    fields: [
    {name:"test", title:"test", editorType:"TextItem"},
    {name:"accumulatePremium", title:"Accumulate All Ceded Premiums Into Ending Accounting Period", editorType:"CheckboxItem", showTitle:"false", startRow:"true"},
    {name:"accumulateLoss", title:"Accumulate All Ceded Losses Into Ending Accounting Period", editorType:"CheckboxItem", showTitle:"false", startRow:"true"},
    {name:"efficientLosses", title:"Efficient Losses", editorType:"CheckboxItem", showTitle:"false", startRow:"true"},
    {name:"showClosed", title:"Show Closed Programs/Periods", editorType:"CheckboxItem", showTitle:"false", startRow:"true"}
    ]
    },

    I have attached a screenshot of the current behavior. The "test" item is just there so I could confirm that the checkbox was still rendering in the second column. How would I update the properties so that the checkbox is left-aligned in column 1?

    Thanks,
    Attached Files
Working...
X