Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

    12.0p+ FormItem showOver (and showOverIcons / updateTextBoxOnOver / updateControlOnOver) broken?

    Hi Isomorphic,

    I was trying to disable icon exchange on hover for FormItems as the icons look the same anyway in my application. Similar to your date_control.png / date_control_Over.png.
    This did not work for me. I changed dateItem2 like this in the variousControls sample (v12.1p_2022-08-10):
    Code:
    {
            name: "dateItem2", title: "Date changed",
            editorType: "DateItem",
            showOverIcons: false,
            showOver: false,
            useTextField: true
        },
    With and without the change, I can see calls to the _Over.png. I expected that showOver: false and/or showOverIcons: false would stop this.

    After reading the showOver docs I also tried updatePickerIconOnOver: false, which does seem to work. So I can solve my main issue!

    But updateTextBoxOnOver: false and updateControlOnOver: false in order to disable textItemLite -> textItemLiteOver for the text entry box again did not work.

    Could you check if everything is working here as it should? This applies to 12.0p+ IMHO, but 12.1p is relevant for me right now.

    Best regards
    Blama

    #2
    The picker icon is indeed special, and it's intentional that showOverIcons applies only to application-developer-defined icons in formItem.icons. But we'll clarify and interlink the docs here to make this more obvious.

    We'll check on whether there's something wrong with the properties for CSS control.

    Comment


      #3
      Hi Isomorphic,

      great, thanks. Can you also check that the "big" more general showOver: false is working as expected?

      Best regards
      Blama

      Comment


        #4
        On your initial question about Over styles in a DateItem with useTextField: true - you just need to apply showOver to the item's textField, via item.textFieldProperties.

        Comment


          #5
          Hi Isomorphic,

          ah, I get it. In general this works, e.g. on the 1st TextItem in the sample:
          Code:
                  {name: "text", title:"Text", type:"text", hint: "A plain text field", wrapHintText: false, [B]updateTextBoxOnOver: false[/B]},
          My assumption: DateItem is a CanvasItem and depending on the useTextField setting it either uses a TextItem or three SelectItems with *SelectorProperties.

          showOver: false also works on the 1st TextItem in the sample:
          Code:
                  {name: "text", title:"Text", type:"text", hint: "A plain text field", wrapHintText: false, [B]showOver: false[/B]},
          So I had an unlucky choice here with the DateItem.
          Then the only question is if DateItem should pass down it's configuration like showOver: falseto the actual FormItems it uses. And if not, perhaps the docs should mention that one has to use the more specific properties.

          Thanks you & Best regards
          Blama

          Comment


            #6
            We did some testing with this code in Tahoe, and we couldn't reproduce this issue. showOver: false worked as expected. Tested in 13.1, 13.0, 12.1 and 12.0.

            Code:
            {
                    name: "dateItem2", title: "Date", hint: "<nobr>Direct date input</nobr>",
                    editorType: "DateItem",
                    showOver: false,
                    useTextField: true
            },
            Can you see whether anything is different in your skin or something that could be producing this issue?. Do you see that issue in this sample?

            Regards
            Isomorphic Software

            Comment


              #7
              Hi Isomorphic,

              yes, in that sample.
              Here a video of these two DateItems:
              Code:
              {
                      name: "dateItem2", title: "Date normal", hint: "<nobr>Direct date input</nobr>",
                      editorType: "DateItem",
                      useTextField: true
              },
              {
                      name: "dateItem3", title: "Date noShowOver", hint: "<nobr>Direct date input</nobr>",
                      editorType: "DateItem",
                      showOver: false,
                      useTextField: true
              },
              As you can see, both textboxes have the "blue hover glow" (only expected for the top one) but only the top DateChooser icon has the glow (expected).

              Click image for larger version

Name:	DateItem.gif
Views:	31
Size:	72.1 KB
ID:	268469


              Best regards
              Blama

              Comment


                #8
                OK. We were able to reproduce the issue and a fix has been applied to address it, which will be available as of tomorrow's builds.

                Regards
                Isomorphic Software

                Comment


                  #9
                  Hi Isomorphic,

                  I can see this is working in 12.1p+ now, regardless of the useTextField setting.

                  Thank you & Best regards
                  Blama

                  Comment

                  Working...
                  X