Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

    JDK 17 support for SmartClient v10.0p_2015-06-17

    Hi,

    We are using SmartClient_v10.0p_2020-08-04_Enterprise version in our product with JDK 8.

    Below are the version details from framework.properties from rpc.jar.

    iscVersionNumber: v10.0p_2020-08-04
    iscVersion: v10.0p_2020-08-04/Enterprise Deployment
    iscPackageDate: 2020-08-04


    We are planning to upgrade to JDK 17. Would we get support on the SmartClient version we use to make it work with JDK 17?


    Thanks,
    Divya

    #2
    Your version is about 9 years old and was end-of-lifed about 4 years ago (https://blog.smartclient.com/were-de...lly-old-stuff/).

    We don't know whether you might be able to get that old version working on a new JDK, but if you were to try, we would be unable to help (since support ended 4 years ago).

    The best path forward is to update to the latest available release. SmartClient releases are backwards compatible, so this is generally easy to do.

    Comment


      #3
      Thanks for the update. Is the latest version compatible with JDK 17?

      Comment


        #4
        Of course, yes.

        Comment


          #5
          A follow up question. We need log4j2 support and I can see that 13.1 provides the same as per https://smartclient.com/smartclient-13.1/isomorphic/system/reference/?id=group..serverLogging.

          But 13.1 is marked as development version, could you provide a timeline as to when this will be released so that we can consume it in our production?

          Comment


            #6
            Although you don't need 13.1 to use log4j2, we would recommend moving to 13.1 now. The release is pending due to the need for more samples, not stability or any other issue.

            Comment


              #7
              Thanks for confirming!

              Comment

              Working...
              X