No announcement yet.
  • Filter
  • Time
Clear All
new posts

    autoFitData in expansionRelatedProperties.

    SmartClient Version : Version v9.0
    Browser : IE9

    Hi, we have a list grid with the ability to expand rows. We want the child grids to autofit vertically and we used the autoFitData property in the expansionRelatedProperties, but is does not seem to have any affect.

    canExpandRecords: true,
    canExpandMultipleRecords: true,
    autoFetchData: true,
    expansionMode: "related",
    expansionRelatedProperties: {autoFitData : "vertical" }

    I see that as the the example given in smartClient it displays 4 rows and then a scroll bar appears if there are more rows.

    I tried to set the expansionRelatedProperties: {autoFitData : "vertical" } to the smartclient example and it did not see to have any affect either.

    We tried a scenario of setting the height to a value, but the problem was we see a lot of blank space in the bottom if the child grid has very rows.

    Do we need to use any other property to sutoFitData for expansion related grids (child grids)

    any suggestions please.


      There are some existing defaults for the expansionRelated autoChild - one of these is autoFitData: "vertical" - so setting this yourself in the Feature Explorer sample won't change anything.

      Another default setting is autoFitMaxRecords: 4. So the Smartclient example autofits to a maximum of four rows before adding a scrollbar.

      What is it that you're trying to achieve? It sounds like this is what you want, but you just don't want to set that limit of 4 records - ie, you want the child grid to expand to show *all* records?

      If so, you can use:

      exansionRelatedProperties: {
          autoFitMaxRecords: 0
      If you're after something else, please clarify.


        Thank you for the reply.

        This is what we were looking for. By setting the autoFitMaxRecords: 0, property we noticed that child grid expands as per the number of rows.


          Setting autoFitMaxRecords to 0 works only rows less than 40, if we get more that 40, it's blank and focusing on the grid and minimize/maximize window reveals the data.

          So we set the autoFitMaxRecords to 1000, and then setting the height seems to work fine.

          Are we missing something or doing something wrong here.


            It sounds like there may be a real bug. We see you've opened another thread on this here.
            We'll take a look and follow up with you there.

            Isomorphic Software