Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • subashk
    replied
    We were able to disable the prompt by setting the showPrompt= false in the Datasource (.ds.xml) file used by the form.

    Some thing like this

    <DataSource ID="testDS" serverType="generic" showPrompt="false">
    <fields>
    <field name="field1"/>
    </fields>
    <serverObject lookupStyle="new"
    className="some class name"/>
    </DataSource>

    Leave a comment:


  • Isomorphic
    replied
    See RPCRequest.showPrompt and promptStyle.

    Leave a comment:


  • Disabling "saving form ...." prompt when submitting form

    SmartClient Version: v9.0p_2013-11-03/PowerEdition
    Browsers: All

    We have a dynamic form with one select field and a button which upon clicking will call the saveData on the form. While waiting for the response the "Saving Form" popup is displayed.

    We would like to find out if there is a way to disable the popup.

    The following is a sample of our code.

    isc.DynamicForm.create({
    ID: "testForm",
    width:"245", numCols:2,
    dataSource:"testDS",
    autoDraw:false,
    fields: [
    {title:"units",showTitle:false, type:"select", valueMap:"unitsValueMap", name: "units",defaultValue:"", width:60},
    {name:"save", title:"Submit", editorType:"button", width:110, align:"right", endRow: false, startRow: false,
    click: function(){
    this.form.saveData(
    function(dsResponse, data, dsRequest) {
    if(dsResponse.status == 10){
    isc.say(data);
    }else{
    isc.say("There was an error in submitting the form");
    }
    }
    , {
    params: {
    param1 : val1,
    param2 : val2
    }
    });
    }
    }
    ]
    });
Working...
X