No announcement yet.
  • Filter
  • Time
Clear All
new posts

    Problem installing the developer console

    Browser: Chrome Version 57.0.2987.133 (64-bit)
    IDE: Eclipse Version: Neon.3 Release (4.6.3)


    After dealing more than 3 days trying to figure out how to install the smartgwt-6.0p (LGPL SDK) into my GWT 2.8 project, I'm having problems with the developer console. I use ANT and IVY and I don't use the GWT plugin for eclipse.

    Running the APP in development mode (ant devmode) I have the following error in the browser console (it opens the following URL but there is nothing inside, so debugging I found I have to called:

    Log.html:59 Uncaught ReferenceError: isc is not defined
        at Log.html:59
    (anonymous) @ Log.html:59
    Log.html:60 GET
    Log.html:65 GET
    Log.html:66 GET
    Log.html:61 GET
    Log.html:68 GET$systemSchema
    Log.html:95 GET
    Log.html:70 GET
    Log.html:63 GET
    Log.html:62 GET
    Log.html:64 GET
    Log.html:69 GET
    Log.html:63 GET
    Log.html:64 GET
    Log.html:65 GET
    Log.html:66 GET
    Log.html:68 GET$systemSchema
    Log.html:69 GET
    Log.html:70 GET
    load_skin.js?isc_version=v11.0p_2017-04-03.js:7 Uncaught ReferenceError: isc is not defined
        at load_skin.js?isc_version=v11.0p_2017-04-03.js:7
    (anonymous) @ load_skin.js?isc_version=v11.0p_2017-04-03.js:7
    Log.html:81 Uncaught ReferenceError: isc is not defined
        at Log.html:81
    (anonymous) @ Log.html:81
    Log.html:90 Uncaught ReferenceError: isc is not defined
        at Log.html:90
    (anonymous) @ Log.html:90
    Log.html:95 GET
    My module (gwt.xml) is set up as follows:

    <?xml version="1.0" encoding="UTF-8"?>
    <!-- When updating your version of GWT, you should also update this DTD reference,
        so that your app can take advantage of the latest GWT module capabilities. -->
    <!DOCTYPE module PUBLIC "-//Google Inc.//DTD Google Web Toolkit 2.8.0//EN"
    <module rename-to='module'>
        <!-- Inherit the core Web Toolkit stuff. -->
        <inherits name='' />
        <inherits name="com.smartgwt.SmartGwt"/>
        <!-- Other module inherits -->
        <!-- Specify the app entry point class. -->
        <entry-point class='com.example.example.client.Example' />
        <!-- Specify the paths for translatable code -->
        <source path='client' />
        <!-- allow Super Dev Mode -->
        <add-linker name="xsiframe" />
    The hosted page:

    [HTML]<!doctype html>
    <!-- The DOCTYPE declaration above will set the -->
    <!-- browser's rendering engine into -->
    <!-- "Standards Mode". Replacing this declaration -->
    <!-- with a "Quirks Mode" doctype is not supported. -->

    <meta http-equiv="content-type" content="text/html; charset=UTF-8">

    <link type="text/css" rel="stylesheet" href="Module.css">
    <link type="text/css" rel="stylesheet" href="module/sc/skins/Enterprise/skin_styles.css">


    <script src="module/sppal.nocache.js"></script>
    <script src="module/sc/modules/ISC_Core.js"> </script>
    <script src="module/sc/modules/ISC_Foundation.js"> </script>
    <script src="module/sc/modules/ISC_Containers.js"> </script>
    <script src="module/sc/modules/ISC_Grids.js"> </script>
    <script src="module/sc/modules/ISC_Forms.js"> </script>
    <script src="module/sc/modules/ISC_RichTextEditor.js"></script>
    <script src="module/sc/modules/ISC_Calendar.js"> </script>
    <script src="module/sc/modules/ISC_DataBinding.js"> </script>



    <!-- RECOMMENDED if your web app will not function without JavaScript enabled -->
    style="width: 22em; position: absolute; left: 50%; margin-left: -11em; color: red; background-color: white; border: 1px solid red; padding: 4px; font-family: sans-serif">
    Your web browser must have JavaScript enabled in order for this
    application to display correctly.</div>

    <h1>Set up Smartgwt</h1>

    <div id="main"></div>


    I would be thankful for any kind of support. By the way, I checked already this:
    Last edited by karlihnos; 5 Apr 2017, 04:51.

    Hi karlihnos,

    basically the same as in your other thread. Most likely you are missing
    <script type="text/javascript">var isomorphicDir = "yourproj/sc/";>"</script>
    in your mail html file. Make it match the directory structure on the webserver so that there are no longer the 404s you are seeing.
    Generally speaking, you should see no 404s at all.

    Also, your call to
    <script src="name-module/name-module.nocache.js"></script>
    MUST come after the ISC-includes.
    Best is to download the EE-Eval and to look into the BuiltInDS sample there for the correct order.

    Also you should load the load_skin.js and not the skin_styles.css, again see the BuiltInDS sample.

    Best regards
    Last edited by Blama; 5 Apr 2017, 07:21.


      Thank you Blama for the support. It works now using the smartgwt LGPL and smartgwtEE