Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

    Console logs JSP ERROR - v12.0p_2020-01-02/PowerEdition Deployment

    Hi IsoMorphic,

    After upgrading to v12.0 version (before it was aa 9.1p) we are facing the following error while opening isc.showConsole():

    ene 21, 2020 9:20:17 AM org.apache.catalina.core.StandardWrapperValve invoke
    GRAVE: Servlet.service() para servlet jsp lanzó excepción
    java.lang.Exception: send(rpcRequest, rpcResponse) called twice for the same rpcRequest. Only one RPCResponse can be sent to an RPCRequest.
    at com.isomorphic.rpc.RPCManager.send(RPCManager.java:650)
    at com.isomorphic.rpc.RPCManager.sendFailure(RPCManager.java:812)
    at com.isomorphic.rpc.RPCManager.sendFailure(RPCManager.java:828)
    at org.apache.jsp.tools.developerConsoleOperations_jsp._jspService(developerConsoleOperations_jsp.java:130)
    at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
    at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:377)
    at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
    at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:88)
    at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
    at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
    at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
    at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
    at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
    at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
    at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
    at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
    at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
    at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857)
    at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588)
    at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
    at java.lang.Thread.run(Thread.java:745)

    For the upgrade we replaced all the Java dependencias, the JavaScript IsoMorphic folder and the WebContent\tools folder. Everything seems to work but the console not. Also, although this errors appears the console does opens but when you click on "Server Logs" then the same described error occurs on the server (Tomcat 6) and the the following message appears on the client interface:

    Failed to get log data - error: Transport error -HTTP code: 500 for URL:
    http://localhost:9090/MapaSc/tools/d...=1&isc_noLog=1

    Have tested with Tomcats 6, 7, 8, 9 with no success. On WebLogic 12 it works


    Click image for larger version  Name:	Captura.JPG Views:	0 Size:	35.0 KB ID:	260808

    Please let us know what can be the cause of this erros and how o solve theme. Thank you in advance.
    Last edited by jcastroredur; 21st Jan 2020, 03:46.

    #2
    It's not clear what would cause this exception from your description, but it's almost certainly going to be a problem with the upgrade process as we've not had any other reports of this exception with 12.0 (and it seems to be working for you in some server environments)

    We'd recommend going through the installation instructions step by step here:
    https://www.smartclient.com/smartcli...up..iscInstall

    It seems likely you may have missed a step. For the configuration files (web.xml / server.properties) you may be merging rather than copying the files across if you already have configuration in your existing 9.0 deployment you want to keep - but that should not be too difficult to achieve (as you know what the local configuration you need to preserve is!):

    If that doesn't resolve your issues, it's not clear what to suggest. At a guess, there may be some aggressive server cacheing or similar going on that's causing stale resources to be used on the back end. You can check the Tomcat documentation and support for how to deal with that.

    Hope this helps
    Isomorphic Software

    Comment

    Working...
    X