Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • JavaScriptException when upgrading SmartGWT

    Hey Isomorphic,

    I'm in the process of attempting to upgrade from SmartGWT 3.1 to SmartGWT 4.0 and receive the following Error (characterized by the following stack trace) below:

    ERROR: Uncaught exception escaped
    com.google.gwt.core.client.JavaScriptException: (TypeError) @com.google.gwt.core.client.impl.Impl::apply(Ljava/lang/Object;Ljava/lang/Object;Ljava/lang/Object;)([JavaScript object(1305), JavaScript object(1303), JavaScript object(1313)]): isc.isA.SGWTFactoryObject is not a function
    at com.google.gwt.dev.shell.BrowserChannelServer.invokeJavascript(BrowserChannelServer.java:249)
    at com.google.gwt.dev.shell.ModuleSpaceOOPHM.doInvoke(ModuleSpaceOOPHM.java:136)
    at com.google.gwt.dev.shell.ModuleSpace.invokeNative(ModuleSpace.java:571)
    at com.google.gwt.dev.shell.ModuleSpace.invokeNativeObject(ModuleSpace.java:279)
    at com.google.gwt.dev.shell.JavaScriptHost.invokeNativeObject(JavaScriptHost.java:91)
    at com.google.gwt.core.client.impl.Impl.apply(Impl.java)
    at com.google.gwt.core.client.impl.Impl.entry0(Impl.java:242)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.google.gwt.dev.shell.MethodAdaptor.invoke(MethodAdaptor.java:103)
    at com.google.gwt.dev.shell.MethodDispatch.invoke(MethodDispatch.java:71)
    at com.google.gwt.dev.shell.OophmSessionHandler.invoke(OophmSessionHandler.java:172)
    at com.google.gwt.dev.shell.BrowserChannelServer.reactToMessages(BrowserChannelServer.java:293)
    at com.google.gwt.dev.shell.BrowserChannelServer.processConnection(BrowserChannelServer.java:547)
    at com.google.gwt.dev.shell.BrowserChannelServer.run(BrowserChannelServer.java:364)
    at java.lang.Thread.run(Thread.java:662)

    This occurs in the LGPL edition of SmartGWT 4.0, built on December 17, 2013. All browsers are affected, as this is a problem that is thrown on startup of the application and causes the load to fail completely.

    The company I work for uses SmartGWT for a number of applications and a number of others work fine with the new (4.0) files, but this one obviously does not. Please tell me if you would like any sample code posted, as I am unsure what code you might need to aid me in debugging this issue, seeing as the stack trace is a bit unhelpful.

    Thank you!

  • #2
    This is almost certainly just a broken installation, using older JavaScript files with newer SmartGWT wrapper code. Use the instructions in the FAQ to verify the versions of the .js files being loaded.

    Comment


    • #3
      Thanks for the quick reply!

      I have followed the instructions to the best of my ability (LGPL does not have a few of the files listed in the instructions) and re-copied every JavaScript file in the smartgwt and smartclient folders to their correct locations in our projects and ensured that the proper versions were being used. However, the problem still persists and contains the same error message as before.

      Are there any other suggestions you may have or should I continue to dive into JavaScript files and version labels?

      Thanks!

      Comment


      • #4
        Same suggestion - read the FAQ to see how to check what version you are actually loading.

        Comment

        Working...
        X