No announcement yet.
  • Filter
  • Time
Clear All
new posts

    Installing GWT (SmartGWT) Eclipse Plugin "offline"

    Has anyone successfully installed the GWT Eclipse plugin without an Internet connection available? We've been able to successfully get the demo SGWT application working without trouble, but not a development environment.

    If I grab a GWT offline update archive (zip), it still appears to reach out for what I believe is a Maven site (m2e), so it still fails to install without a connection.

    I've also tried installing on a PC with an Internet connection (this works perfectly), and then copying the Eclipse directory along with the Eclipse workspace over to the other disconnected PC, using that same workspace on the disconnected machine. When I do that, the target PC does not have a "G" drop menu and does not have a "Google" section in Window->Preferences. Instead it says "Designer" which is supposed to be a subsection of the Google menu.

    I'm using Eclipse Juno with the Google Plugin for Eclipse 3.8/4.2 (Juno). I've tried running Eclipse as administrator, same result.

    Nothing in SmartGWT would cause any kind of additional network requests or requirements for a network connection from within Eclipse, so you can probably find people experiencing the same issues on the general GWT forums.

    As far as how to fix it, we've never had a reason to try this, but a possible approach would be to get your project completely set up from a command-line perspective and just have Eclipse import it once all relevant resources have been downloaded.

    As far as Maven being involved in particular, organizations that want to use Maven but are uncomfortable with it automatically pulling down dependencies from the internet at large will generally install a local/internal Maven repo and configure Maven to pull resources only from there.


      This seems to be a common issue amongst enterprise customers, so the hope was that you'd have a known workaround.

      The core issue isn't setting up a project, it's installing the Google GWT plugin which is "highly recommended" using SmartGWT. Before we can commit to purchasing anything, we'd need to find a comfortable workaround. "Comfortable" meaning we're reasonably confident that it will continue to work in the coming years.

      We're not giving up so easily but any suggestions will be helpful.


        While it's possible this is a a common issue, you'll note it's never come up in the 10s of thousands of threads here. That's because, while it makes sense to discuss things that might be bugs in third party products like Eclipse or Tomcat if they are triggered in some way by SmartGWT, this is an example where SmartGWT is wholly uninvolved in the problem.

        There's nothing we can change or adjust in SmartGWT or its sample projects that would influence this behavior, and obviously, we also can't release a fix for the problem if it's a GWT bug, since it's not our product.

        That's why it makes sense to take this to the general GWT forums - it's about GWT as such, and the problem is most simply explained omitting SmartGWT entirely.

        Just for completeness:

        1. if you'd like a more guided approach to our product, where Isomorphic staff would dive into and solve issues you're having with third-party products, consider our commercial services.

        2. if you want to use the same product without involving GWT, use our product SmartClient. It's exactly the same feature set (and same runtime), but you write your UI code in JavaScript and do not use GWT


          I don't disagree, GWT research is where I've focused from the beginning. But we can't adopt SGWT unless we get past this issue with its 3rd party (recommended) dependency (GWT plugin).


            We understand, at the same time, we hope you understand that it doesn't make sense for Isomorphic to launch into an investigation of an atypical usage of a third party product hoping to chance upon the same problem you've hit, hoping further that we might be able to solve it despite it being not our product and not even the part of the product that relates to what we do..

            Anyway, if this need is common, you should find either that there are others reporting the same problem, or that it's actually working if you redo the documentated procedure from the top (perhaps on a second machine). If not, we've given a couple of other ways to proceed.