No announcement yet.
  • Filter
  • Time
Clear All
new posts

    BUG: [WARN] 404 - GET /myapp/sc/skins/standard/images/blank.gif (

    I got this error everytime I try disable some form component. The form get really ugly.

    I check the dir and that image is missing.

    anyway, I thought I should warn.

    [WARN] 404 - GET /myapp/sc/skins/standard/images/blank.gif ( 1430 bytes

    You probably have multiple skins loaded. Check your module file. If you go to the showcase and select the "Disabled Mode" checkbox before clicking on an icon for a sample you'll see that the disabled version of the sample displays correctly.


      I just have the enterprise.

      also, im using nightlybuild. so i dont know whats the problem.

      <inherits name="com.smartgwt.SmartGwt" />
      <inherits name="com.smartclient.theme.enterprise.Enterprise"/>

      also, i delete my sc dir to check how the smartgwt-skin will be extract. I only have sc/skins/Enterprise folder.


        Create a standalone project that demonstates the issue. Its definitely a problem with your configuration and posting partial information is not sufficient. Always post a complete and minimal standalone testcase when you claim to have found a bug.


          Browser: Chrome Version 57.0.2987.133 (64-bit)
          IDE: Eclipse Version: Neon.3 Release (4.6.3)
          GWT 2.8

          I confirm this Bug using.

          public class Sppal implements EntryPoint {
              public void onModuleLoad(){
                  final Dialog dialog = new Dialog();
                    dialog.setMessage("Please choose whether to proceed");

          <?xml version="1.0" encoding="UTF-8"?>
          <!-- When updating your version of GWT, you should also update this DTD reference,
              so that your app can take advantage of the latest GWT module capabilities. -->
          <!DOCTYPE module PUBLIC "-//Google Inc.//DTD Google Web Toolkit 2.8.0//EN"
          <module rename-to='module'>
              <!-- Inherit the core Web Toolkit stuff. -->
              <inherits name='' />
              <inherits name="com.smartgwt.SmartGwt" />
              <inherits name="com.smartclient.theme.enterprise.Enterprise" />
              <!-- Other module inherits -->
              <!-- Specify the app entry point class. -->
              <entry-point class='com.example.start.client.Start' />
              <!-- Specify the paths for translatable code -->
              <source path='client' />
              <!-- allow Super Dev Mode -->
              <add-linker name="xsiframe" />
          Hosted page:

          <!doctype html>
          <!-- The DOCTYPE declaration above will set the     -->
          <!-- browser's rendering engine into                -->
          <!-- "Standards Mode". Replacing this declaration   -->
          <!-- with a "Quirks Mode" doctype is not supported. -->
          <meta http-equiv="content-type" content="text/html; charset=UTF-8">
          <link type="text/css" rel="stylesheet" href="Start.css">
          <script src="name-module/name-module.nocache.js"></script>
          <script src="name-module/sc/modules/ISC_Core.js">          </script>
          <script src="name-module/sc/modules/ISC_Foundation.js">    </script>
          <script src="name-module/sc/modules/ISC_Containers.js">    </script>
          <script src="name-module/sc/modules/ISC_Grids.js">         </script>
          <script src="name-module/sc/modules/ISC_Forms.js">         </script>
          <script src="name-module/sc/modules/ISC_RichTextEditor.js"></script>
          <script src="name-module/sc/modules/ISC_Calendar.js">      </script>
          <script src="name-module/sc/modules/ISC_DataBinding.js">   </script>
              <!-- RECOMMENDED if your web app will not function without JavaScript enabled -->
                      style="width: 22em; position: absolute; left: 50%; margin-left: -11em; color: red; background-color: white; border: 1px solid red; padding: 4px; font-family: sans-serif">
                      Your web browser must have JavaScript enabled in order for this
                      application to display correctly.</div>
              <h1>Set up Smartgwt</h1>
              <div id="main"></div>
              <div id="dialog"></div>

          Error in the browser console:

          GET 404 (Not Found)  - ISC_Core.js:2786
          GET 404 (Not Found)   - close.gif:1
          GET 404 (Not Found) - headerGradient.gif:1
          Last edited by karlihnos; 5 Apr 2017, 06:30.


            Hi karlihnos,

            most likely you are missing
            <script type="text/javascript">var isomorphicDir = "yourproj/sc/";>"</script>
            in your mail html file. Make it match the directory structure on the webserver so that there are no longer the 404s you are seeing.

            Also, your call to
            <script src="name-module/name-module.nocache.js"></script>
            MUST come after the ISC-includes.
            Best is to download the EE-Eval and to look into the BuiltInDS sample there for the correct order.

            Best regards