Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • ListGrid setCanReorderRecords throws exception when dragging record.

    Running SmartGWT 6.0p-eval. When I set listGrid.setCanReorderRecords (true) and then try to reorder records via the mouse I get the following exception (many depending on how long I drag the mouse):

    15:36:34.075:MMV9:WARN:Log:Uncaught exception escaped: com.google.gwt.core.client.JavaScriptException
    (TypeError) : retVal_0_g$.booleanValue_0_g$ is not a function
    at anonymous(Canvas.java:11644)
    at gvc_g$(Impl.java:233)
    at jvc_g$(Impl.java:285)
    at anonymous(Impl.java:71)
    The record appears to drag but does not reorder when dropped. Also the dotted red line indicating where the record would drop does not appear.

    I tried copying the example code from http://www.smartclient.com/smartgwt/...n_drag_reorder verbatim and got the same result.

    Any idea what might be wrong?

    Thanks


  • #2
    Take a look at the SmartGWT Developer Console as the first step to troubleshooting JavaScript errors. See the FAQ and/or the Debugging overview in the docs for further details.

    Comment


    • #3
      Hi all,

      it is working for me (not the OP) in the online showcase in FF26, Chromium 52, Edge 13.

      @Isomorphic:
      I found a problem with the sample though. While multi-record drag and drop works, the up/down/first/last buttons don't work for multi-selections in a similar way.
      Expected behavior for first/last: Move the selected records to top/bottom, don't change order of selected records (or disable buttons for multi-selections).
      Expected behavior for up/down: Move every selected records one position up/down, don't change order of selected records (or disable buttons for multi-selections).

      Best regards
      Blama

      Comment


      • #4
        The problem is just that the code in this example only handles a single selected record. It's not a framework bug. We'll fix the sample code.

        Comment


        • #5
          The sample code has been fixed. Please try the next nightly build, dated August 19.

          Regards
          Isomorphic Software

          Comment


          • #6
            Found my issue, I was running with GWT-2.8.0-beta1 needed to be GWT-2.8.0-rc1.

            Thanks for your help.

            Comment

            Working...
            X