Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • Can't load DataSources - SmartClient runtime not loaded

    hi ,guys!
    when i run the demo built-in-ds ,alert "Can't load DataSources - SmartClient runtime not loaded"
    but the log shows everything goes well,what's the problem?

    here is log from idea!

    Code:
    The code server is ready at http://127.0.0.1:9876/
    Code server started in 275575 ms
    waited 259148 ms for code server to finish
    Dev Mode initialized. Startup URL:
    http://127.0.0.1:8888/BuiltInDS.html
    === 2017-03-14 13:45:02,274 [6-30] DEBUG Compression - /BuiltInDS.html: Result is zero length - not compressing
    === 2017-03-14 13:45:02,391 [6-29] INFO Compression - /builtinds/builtinds.nocache.js: 2473 -> 1220 bytes
    === 2017-03-14 13:45:02,391 [6-29] DEBUG ServletTools - setting cookie 'isc_cState' to: 'ready'
    === 2017-03-14 13:45:02,501 [6-26] INFO RequestContext - URL: '/builtinds/loadScriptTagFiles.js', User-Agent: 'Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36': Safari with Accept-Encoding header
    === 2017-03-14 13:45:02,512 [6-31] INFO RequestContext - URL: '/builtinds/sc/DataSourceLoader', User-Agent: 'Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36': Safari with Accept-Encoding header
    [WARN] 404 - GET /builtinds/loadScriptTagFiles.js (127.0.0.1) 1396 bytes
    Request headers
    Host: 127.0.0.1:8888
    Connection: keep-alive
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
    Accept: */*
    Referer: http://127.0.0.1:8888/BuiltInDS.html
    Accept-Encoding: gzip, deflate, sdch, br
    Accept-Language: zh-CN,zh;q=0.8
    Cookie: explorerLayout=%7B%22collapsed%22%3A%5B%5D%7D
    Response headers
    Content-Type: text/html;charset=ISO-8859-1
    Cache-Control: must-revalidate,no-cache,no-store
    Content-Length: 1396
    === 2017-03-14 13:45:02,630 [6-31] DEBUG XML - Parsed XML from C:\Users\Administrator\.IntelliJIdea2016.2\system\gwt\smart-gwt.9e2c16f8\smart-gwt.3c722a70\run\www\builtinds\sc\system\schema\builtinTypes.xml: 9ms
    === 2017-03-14 13:45:02,689 [6-31] INFO PoolManager - SmartClient pooling started for 'simpleTypes' objects
    === 2017-03-14 13:45:02,869 [6-31] DEBUG XML - Parsed XML from C:\Users\Administrator\.IntelliJIdea2016.2\system\gwt\smart-gwt.9e2c16f8\smart-gwt.3c722a70\run\www\ds\supplyItem.ds.xml: 13ms
    === 2017-03-14 13:45:02,924 [6-31] DEBUG XML - Parsed XML from C:\Users\Administrator\.IntelliJIdea2016.2\system\gwt\smart-gwt.9e2c16f8\smart-gwt.3c722a70\run\www\builtinds\sc\system\schema\DataSource.ds.xml: 55ms
    === 2017-03-14 13:45:03,108 [6-31] DEBUG XML - Parsed XML from C:\Users\Administrator\.IntelliJIdea2016.2\system\gwt\smart-gwt.9e2c16f8\smart-gwt.3c722a70\run\www\builtinds\sc\system\schema\DataSourceField.ds.xml: 4ms
    === 2017-03-14 13:45:03,193 [6-31] DEBUG XML - Parsed XML from C:\Users\Administrator\.IntelliJIdea2016.2\system\gwt\smart-gwt.9e2c16f8\smart-gwt.3c722a70\run\www\builtinds\sc\system\schema\ValueMap.ds.xml: 2ms
    === 2017-03-14 13:45:03,204 [6-31] DEBUG XML - Parsed XML from C:\Users\Administrator\.IntelliJIdea2016.2\system\gwt\smart-gwt.9e2c16f8\smart-gwt.3c722a70\run\www\builtinds\sc\system\schema\Validator.ds.xml: 4ms
    === 2017-03-14 13:45:03,284 [6-31] DEBUG SQLDataSource - DataSource 10 acquired SQLDriver instance 1439744200 during initialization
    === 2017-03-14 13:45:03,287 [6-31] DEBUG DataSourceLoader - For DataSource 'supplyItem', got instanceId 10
    === 2017-03-14 13:45:03,320 [6-31] WARN JSTranslater - disableStringInBrowser = false
    === 2017-03-14 13:45:03,322 [6-31] DEBUG SQLDataSource - About to clear SQLDriver state for DS instance 10
    === 2017-03-14 13:45:03,322 [6-31] DEBUG SQLDataSource - About to clear SQLDriver state for DS instance 10
    === 2017-03-14 13:45:03,326 [6-31] DEBUG XML - Parsed XML from C:\Users\Administrator\.IntelliJIdea2016.2\system\gwt\smart-gwt.9e2c16f8\smart-gwt.3c722a70\run\www\ds\animals.ds.xml: 3ms
    === 2017-03-14 13:45:03,375 [6-31] DEBUG SQLDataSource - DataSource 14 acquired SQLDriver instance 634114713 during initialization
    === 2017-03-14 13:45:03,375 [6-31] DEBUG DataSourceLoader - For DataSource 'animals', got instanceId 14
    === 2017-03-14 13:45:03,400 [6-31] DEBUG SQLDataSource - About to clear SQLDriver state for DS instance 14
    === 2017-03-14 13:45:03,400 [6-31] DEBUG SQLDataSource - About to clear SQLDriver state for DS instance 14
    === 2017-03-14 13:45:03,404 [6-31] DEBUG XML - Parsed XML from C:\Users\Administrator\.IntelliJIdea2016.2\system\gwt\smart-gwt.9e2c16f8\smart-gwt.3c722a70\run\www\ds\employees.ds.xml: 3ms
    === 2017-03-14 13:45:03,430 [6-31] DEBUG SQLDataSource - DataSource 18 acquired SQLDriver instance 1470536887 during initialization
    === 2017-03-14 13:45:03,430 [6-31] DEBUG DataSourceLoader - For DataSource 'employees', got instanceId 18
    === 2017-03-14 13:45:03,441 [6-31] DEBUG SQLDataSource - About to clear SQLDriver state for DS instance 18
    === 2017-03-14 13:45:03,441 [6-31] DEBUG SQLDataSource - About to clear SQLDriver state for DS instance 18
    === 2017-03-14 13:45:03,452 [6-31] INFO Compression - /builtinds/sc/DataSourceLoader: 4796 -> 1918 bytes
    === 2017-03-14 13:45:03,452 [6-31] DEBUG ServletTools - setting cookie 'isc_cState' to: 'ready'
    Last edited by mayun; 13th Mar 2017, 22:18.

  • #2
    Isomorphic hi, can you help me out ? :):p

    Comment


    • #3
      log from firefox :

      Code:
      loadScriptTagFiles.js Failed to load resource: the server responded with a status of 404 (Not Found)
      DataSourceLoader:2 Uncaught ReferenceError: isc is not defined
      at DataSourceLoader:2
      https://cr-input.mxpnl.net/data?_cha...23&_app=cs-dca Failed to load resource: net::ERR_NAME_NOT_RESOLVED
      http://cdnsure.com/data/video Failed to load resource: net::ERR_NAME_NOT_RESOLVED
      http://127.0.0.1:8888/favicon.ico Failed to load resource: the server responded with a status of 404 (Not Found)
      builtinds-0.js:12140 Core SmartClient JavaScript libraries appear not to be loaded.
      If inheriting the NoScript SmartGWT modules, verify that the HTML file includes <script src=...> tags to load the SmartClient module .js files from the appropriate location within the WAR.
      By default these files are present under [GWT app name]/sc/modules/.
      builtinds-0.js:12135 com.smartgwt.client.core.JsObject$SGWT_WARN: Core SmartClient JavaScript libraries appear not to be loaded.
      If inheriting the NoScript SmartGWT modules, verify that the HTML file includes <script src=...> tags to load the SmartClient module .js files from the appropriate location within the WAR.
      By default these files are present under [GWT app name]/sc/modules/.
      at fillInStackTrace_0_g$
      at Throwable_2_g$
      at Exception_2_g$
      at JsObject$SGWT_WARN_1_g$
      at init_6_g$
      at onModuleLoad_3_g$
      at onModuleLoad_4_g$
      at init_2_g$
      at initializeModules_0_g$
      at apply_0_g$
      at entry0_0_g$
      at anonymous
      at gwtOnLoad_0_g$
      at anonymous
      
      error_1_g$ @ builtinds-0.js:12135
      builtinds-0.js:134808 Uncaught TypeError: Cannot read property 'Dialog' of undefined
      at initMessages_0_g$ (builtinds-0.js:134808:15)
      at init_8_g$ (builtinds-0.js:134743:5)
      at SmartGwtSuperDevModeEntryPoint_1_g$.onModuleLoad_3_g$ [as onModuleLoad_6_g$] (builtinds-0.js:61788:5)
      at SmartGwtSuperDevModeEntryPoint_1_g$.onModuleLoad_4_g$ [as onModuleLoad_6_g$] (builtinds-0.js:61942:50)
      at Array.init_2_g$ (builtinds-0.js:43243:66)
      at initializeModules_0_g$ (builtinds-0.js:221:30)
      at apply_0_g$ (builtinds-0.js:10845:28)
      at entry0_0_g$ (builtinds-0.js:10915:14)
      at builtinds-0.js:10881:14
      at gwtOnLoad_0_g$ (builtinds-0.js:234:40)
      at builtinds-0.js:273232:1
      Last edited by mayun; 13th Mar 2017, 22:18.

      Comment


      • #4
        The logs are telling you exactly what's wrong and what to fix:

        builtinds-0.js:12140 Core SmartClient JavaScript libraries appear not to be loaded. If inheriting the NoScript SmartGWT modules, verify that the HTML file includes <script src=...> tags to load the SmartClient module .js files from the appropriate location within the WAR. By default these files are present under [GWT app name]/sc/modules/. builtinds-0.js:12135 com.smartgwt.client.core.JsObject$SGWT_WARN: Core SmartClient JavaScript libraries appear not to be loaded. If inheriting the NoScript SmartGWT modules, verify that the HTML file includes <script src=...> tags to load the SmartClient module .js files from the appropriate location within the WAR. By default these files are present under [GWT app name]/sc/modules/.

        Comment


        • #5
          Isomorphic hi, i just use the sample: built-in-ds ,and js has been included into the BuiltInDs.html

          Code:
              <script> var isomorphicDir = "builtinds/sc/";</script>  
              <script type="text/javascript" language="javascript" src="builtinds/builtinds.nocache.js"></script>
              <script type="text/javascript" language="javascript" src="builtinds/loadScriptTagFiles.js"></script>
          When i visit the url path:here is screenshot ,so i'm very confused!
          Last edited by mayun; 14th Mar 2017, 22:08.

          Comment


          • #6
            Click image for larger version

Name:	3242.jpg
Views:	1
Size:	123.1 KB
ID:	243480
            Last edited by mayun; 14th Mar 2017, 22:00.

            Comment


            • #7
              The screenshot shows that the Framework files are in the wrong location. They should be at http://127.0.0.1:8888/builtinds/sc/modules

              Are you running in Eclipse using the GWT Plugin, or building your app from the command line?

              Comment


              • #8
                Isomorphic hi Isoomorphic,i'm very very appreciate your help and your patience!
                1. i'm running in Intellij IDEA using the GWT plugin ,here is my project screenshot

                Click image for larger version

Name:	QQˆ›20170315225031.png
Views:	1
Size:	73.7 KB
ID:	243504

                2. when i start with debug ,there is no exception or error generated ! please see my debug configurations:

                Click image for larger version

Name:	QQˆ›20170315231234.png
Views:	1
Size:	56.2 KB
ID:	243508

                3.The browser startup with these error

                Click image for larger version

Name:	QQˆ›20170315230201.png
Views:	2
Size:	118.3 KB
ID:	243506


                4. The New Tab

                Click image for larger version

Name:	QQˆ›20170315230352.png
Views:	1
Size:	70.3 KB
ID:	243507


                as the error tell me ,the isc is not defined ,but i 'm confused with the load sequence

                Thank you again Isoomorphic!!! Best Wishes!
                Attached Files

                Comment


                • #9
                  Isomorphic hi isomorphic,can you help me? thank you ! ;)
                  Last edited by mayun; 15th Mar 2017, 21:28.

                  Comment


                  • #10
                    i resolve the problem. Change the ide to MyEclipse and follow the instruction ,all things is ok

                    Comment


                    • #11
                      Hi , I have a similar requirement where i want to change that custom error message (can't load dataSource ) , can you please explain little more how this issue was get resolved .

                      Many thanks in advance .

                      Comment


                      • #12
                        As the previous poster said: just follow the instructions. There is even a troubleshooting guide.

                        There is no point in customizing this error message as your should be ensuring your end users never see it. It can only happen if you completely botch your project setup.

                        Comment

                        Working...
                        X