Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • LieveVdH
    started a topic SmartGWT DateFilterEditor typing dates problem

    SmartGWT DateFilterEditor typing dates problem

    Hi,
    I'm using SmartGWT 6.1p (SmartClient Version: v11.1p_2017-12-14/PowerEdition Deployment (built 2017-12-14)) and I'm having isuues when I try to type in a date in a filter criteria in a ListGrid. When I try to type in the to date my cursor jumps to the from field after typeing the first year character.
    So if I want to type in
    From 01/01/2017
    To 31/01/2018
    After I type the 2 in 2018 my cursor always jumps to behind 2017
    I have tried this in all possible browers, IE, Firefox and Chrome, they all have the same behaviour.
    I already set the DateInputFormat on the DateUtils, I tried changing from Date to DateTime but it all remains the same.
    Any ideas?
    Thank you!

  • Blama
    replied
    Hi Isomorphic,

    then it is perhaps a good idea to make this the default in ListGrids on touch devices?

    Best regards
    Blama

    Leave a comment:


  • Isomorphic
    replied
    You can force the operator icons to be shown in each field via ListGrid.alwaysShowOperatorIcon. Then, long touch over the operator icon will show the operator picklist.

    Leave a comment:


  • Blama
    replied
    Hi Isomorphic,

    I can see that both are solved, but now choosing the filter-operator via right-click (=hold) is not possible in iOS.
    Again: No problem for me and I don't have an idea how to solve this best, either. I just noticed it.

    Best regards
    Blama

    Leave a comment:


  • Isomorphic
    replied
    Originally posted by Blama View Post
    Hi Isomorphic,

    I just tried this using v12.0p_2018-06-04 on an iOS 11 device. Here text-entry stops after the round trip returns and the virtual keyboard is hidden.
    Also, tap+hold to edit the text move the cursor in the textbox (e.g. to remove a typo) will instead trigger the "choose operatorId" context menu.

    Both of these are most likely not intended (but I don't have an idea to fix #2).

    This has no priority for me.

    Best regards
    Blama
    This should be resolved for SGWT 6.1p/SC 11.1p and newer releases in today's builds, dated 2018-06-11.

    Leave a comment:


  • claudiobosticco
    replied
    Originally posted by Isomorphic View Post
    This has been fixed for builds dated June 4 and later - text-entry cursor position should now be retained across filter round-trips.
    I see it's working, thank you very much.
    Tested with:
    SmartClient Version: SNAPSHOT_v12.1d_2018-06-04/AllModules Development Only (built 2018-06-04)
    and
    SmartClient Version: v11.1p_2018-06-04/AllModules Development Only (built 2018-06-04)

    Leave a comment:


  • Blama
    replied
    Hi Isomorphic,

    I just tried this using v12.0p_2018-06-04 on an iOS 11 device. Here text-entry stops after the round trip returns and the virtual keyboard is hidden.
    Also, tap+hold to edit the text move the cursor in the textbox (e.g. to remove a typo) will instead trigger the "choose operatorId" context menu.

    Both of these are most likely not intended (but I don't have an idea to fix #2).

    This has no priority for me.

    Best regards
    Blama

    Leave a comment:


  • Isomorphic
    replied
    This has been fixed for builds dated June 4 and later - text-entry cursor position should now be retained across filter round-trips.

    Leave a comment:


  • claudiobosticco
    replied
    Nope, I still see it using:
    Chrome 67.0.3396.62 (64 bit), Firefox 60.0.1 (64 bit), Safari 11.1 (13605.1.33.1.4) on OSX 10.13.4 (17E202)

    SmartClient Version: v11.1p_2018-05-30/AllModules Development Only (built 2018-05-30)
    and
    SmartClient Version: v12.0p_2018-05-31/AllModules Development Only (built 2018-05-31)

    Leave a comment:


  • Isomorphic
    replied
    claudiobosticco the other developer has just confirmed this as fixed. Can you confirm as well?

    Leave a comment:


  • claudiobosticco
    replied
    Originally posted by stevenEngelen View Post
    steps to reproduce:
    In the Item filter you type "ing" and everything with "ing" is filtered.
    [cut]
    I also noticed that.
    Chrome on OSX

    SmartClient Version: v12.0p_2018-05-31/AllModules Deployment (built 2018-05-31)
    and
    SmartClient Version: v11.1p_2018-05-30/AllModules Development Only (built 2018-05-30)

    Leave a comment:


  • stevenEngelen
    replied
    I have a similar problem and I can reproduce it in your online samples.
    https://www.smartclient.com/smartgwt...daptive_filter

    steps to reproduce:
    In the Item filter you type "ing" and everything with "ing" is filtered.
    now you want to change it to "Adding", so you put your cursor in front of "ing" and start typing but after you type A the cursor jumps to the end so you type "Aingdd".
    This is a complaint in our GWT project and I was hoping there is a solution or workaround for this?

    Thank you.

    Leave a comment:


  • Isomorphic
    replied
    This isn't happening for anyone else (or we'd have lots of reports). First verify that it doesn't happen for you in the online samples, then try to figure out what's different about your application, so you can make it possible for others to reproduce the problem.

    Leave a comment:

Working...
X