Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • myapp/sc/skins/Enterprise/images/TreeGrid/folder.png 404 (Not Found)

    Hi Team,

    I am using : SmartClient Version: v11.1p_2017-07-24/PowerEdition Deployment (built 2017-07-24).

    Chrome gives an error in browser console while loading TreeGrid.
    GET http://{appName}/sc/skins/Enterprise/images/TreeGrid/folder.png 404 (Not Found)

    I tried with the latest SmartGWT version(v11.1p_2018-07-07/PowerEdition Deployment) as well and faced the same issue.
    Other images are being loaded correctly.

    Regards,
    Swati

  • #2
    This kind of thing happens from loading two skins at once. See the QuickStart Guide instructions for changing theme.

    Comment


    • #3
      Only one skin is being loaded. I have checked the treegrid folder in enterprise theme. The image folder.png does not exist.

      Comment


      • #4
        Yes, it doesn’t exist because Enterprise doesn’t use that file, but by loading two skins, you mix definitions from multiple skins, and other skins do use that file. Revisit the QuickStart instructions for how to correctly switch theme.

        You can also verify the problem by watching the network tab and observing that load_skin.js is loaded twice from two different skins (do this with a clear cache).

        Comment


        • #5
          Thanks for the response. I checked the network, and i see only one skin being loaded.
          {myapp}/sc/skins/Enterprise/load_skin.js

          Also the above skin file has reference to folder.png image
          if (isc.TreeGrid) {
          isc.TreeGrid.addProperties({
          alternateRecordStyles:false,
          folderIcon:"[SKIN]folder.png",
          ......

          Am i still missing something.

          Comment


          • #6
            Have you overridden the default values of TreeGrid.closedIconSuffix and TreeGrid.showOpenIcons? If so you may be causing the Framework to look for icon files that aren't normally needed. You will have to create these. Refer also to TreeGrid.folderIcon and TreeGrid.nodeIcon.

            Comment


            • #7
              That was precisely the issue. Thanks a ton!!!

              Comment

              Working...
              X