Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • "-moz-scrollbars-none" is no more working with Firefox 63, overflow: hidden not working

    Hello everybody
    we used for the user interface of a web-application the following version * Isomorphic SmartClient * Version 8.0 (2010-03-03) to create several ineracting windows with a variable content (long lists possible). This worked well all the last years in Firefox, Edge and Chrom. But in August 2018 Firefox decided not to support anymore: "-moz-scrollbars-none", and recommended to use: "overflow: hidden", overflow-x: hidden", "overflow-y: hidden". Release of Firefox 63 definitively banned "-moz-scrollbars-none" from standard configuration of Firefox, but you can still use it when changing Firefox configuration using: "about:config". Search here "overflow" and you will find:" layout.css.overflow.moz-scrollbars.enabled;false" which can be changed to true.
    We analyzed the whole appliaction and "-moz-scrollbars-none" appears only 3times in 2 Files of Isomorphic SmartClient: ISC_Core.js and ISC_RichTextEditor.js


    In ISC_Core.js we have the following code at Line 2011
    ****************************************************************
    {if(this.$ks){_1=this.$se?this.$nz:"-moz-scrollbars-none";this.$r3=true}else{_1=this.$nz}}else if(isc.Browser.isOpera&&this.overflow==isc.Canvas.VISIBLE){_1=this.$nz}else if(isc.Browser.isMoz){if(_4)this.$r3=true;else if(this.$ks){_1=this.$se?this.$nz:"-moz-scrollbars-none";this.$r3=true}}




    ........
    {
    if (this.$ks) {
    _1 = this.$se ? this.$nz : "-moz-scrollbars-none";/* Use «overflow: hidden» ??? */
    this.$r3 = true
    } else {
    _1 = this.$nz
    }
    } else if (isc.Browser.isOpera && this.overflow == isc.Canvas.VISIBLE) {
    _1 = this.$nz
    } else if (isc.Browser.isMoz) {
    if (_4) this.$r3 = true;
    else if (this.$ks) {
    _1 = this.$se ? this.$nz : "-moz-scrollbars-none";/* Use «overflow: hidden» ??? */
    this.$r3 = true
    }
    }
    ......
    ****************************************************************************************

    In ISC_RichTextEditor.js we have the following code at Line 19
    ****************************************************************
    ,isc.A.$rw=function(){if(this.$22y()){var _1;if(this.$ks){_1="-moz-scrollbars-none";this.$r3=true}else{_1=this.$nz}

    ........
    if (this.$22y()) {
    var _1;
    if (this.$ks) {
    _1="-moz-scrollbars-none";/* Use «overflow: hidden» ??? */
    this.$r3=true
    } else {
    _1=this.$nz
    }
    return _1}
    else return this.Super("$rw",arguments)

    ****************************************************************************************

    Does anybody have a quick-fix for this? «overflow: hidden», «overflow-x: hidden» and «overflow-y: hidden» did not yield the desired result in the GUI.

    Werner
    (PS: I am not the developer, we work together with external developers)
    Starts
    11th Dec 2018 03:00

  • #2
    This version is well past end-of-life, you will need to update to a more recent version.

    http://blog.isomorphic.com/its-time-...lly-old-stuff/

    Comment


    • #3
      Thanks for response. Of course it is well known to me that it is best practice to update every two years or so to current updates, however who can pay this work?
      Do you have any idea about which version could yield best results when upgrading? We have very complex Central GUI (starting point of application) with six interacting Subwindows, sliders etc.

      Somebody wrote to me that it is possible to make a hot fix by adding a special Java Script at the end of index.html, and then, problem is solved for a while.

      Or are there any other ideas. Of course, there is also the possibility for a complete reengirnieering, for example with Angular 6 etc. But this is of course very costly and time consuming.

      Thanks in advance for good ideas..

      Comment


      • #4
        Its all JavaScript and so is runtime modifiable, so yes, you could hack around this particular issue. But this version is so old that there will be many other issues in other browsers as well.

        The best approach is simply to update to the latest release, since all of our releases have been backwards compatible.

        Comment


        • #5
          Seems this is a general problem with Firefox 63+ (63.0.x - 65.0.x can be "fixed" with about:config flag "layout.css.overflow.moz-scrollbars.enabled" form "false" to "true", while Firefox 66+ and the upcoming 68 ESR do not handle this at all).

          Solution is to switch off the custom scrollbars in load_skin.js. Took me a while to figure this out (we are still on SmartGWT 3.1 and had the same problem)

          load_skin.js of the current skin:
          ...
          //----------------------------------------
          // 1) Scrollbars
          //----------------------------------------
          isc.Canvas.addProperties({
          showCustomScrollbars: !isc.Browser.isMoz,
          scrollbarSize: 16,
          cornerSize: 16
          })
          ...

          Comment


          • #6
            We use smartgwt-2.5-patch and we tried this solution but the problem still remains .
            can you please tell us how many files did you change ?
            the file load_skin.js is also present in smartgwt-skins-2.5.jar and smartgwt-2.5-patch.jar
            Last edited by mhanne; 25th Apr 2019, 05:36. Reason: we use the the firefox v66 and firefox v63

            Comment

            Working...
            X