Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • Problem with ComboBoxItem in Safari

    Hi Isomorphic,

    please see this testcase:

    Code:
    package com.smartgwt.sample.client;
    
    import com.google.gwt.core.client.EntryPoint;
    import com.smartgwt.client.core.KeyIdentifier;
    import com.smartgwt.client.data.Criteria;
    import com.smartgwt.client.util.Page;
    import com.smartgwt.client.util.PageKeyHandler;
    import com.smartgwt.client.util.SC;
    import com.smartgwt.client.widgets.form.DynamicForm;
    import com.smartgwt.client.widgets.form.fields.ComboBoxItem;
    import com.smartgwt.client.widgets.layout.VStack;
    
    /**
     * Entry point classes define <code>onModuleLoad()</code>.
     */
    public class BuiltInDS implements EntryPoint {
        private DynamicForm boundForm;
    
        /**
         * This is the entry point method.
         */
        public void onModuleLoad() {
            KeyIdentifier debugKey = new KeyIdentifier();
            debugKey.setCtrlKey(true);
            debugKey.setKeyName("D");
    
            Page.registerKey(debugKey, new PageKeyHandler() {
                public void execute(String keyName) {
                    SC.showConsole();
                }
            });
    
            VStack vStack = new VStack();
            vStack.setLeft(175);
            vStack.setTop(75);
            vStack.setWidth("70%");
            vStack.setMembersMargin(20);
    
            boundForm = new DynamicForm();
            boundForm.setDataSource("supplyItem");
            boundForm.setImplicitCriteria(new Criteria("SKU", "99010600"));
            boundForm.setAutoFetchData(true);
            boundForm.setWidth100();
            boundForm.setHeight100();
            boundForm.setFields(new ComboBoxItem("SKU"));
            boundForm.disable();
            vStack.addMembers(boundForm);
            vStack.draw();
        }
    }
    Please run this in Safari on mac.

    Expected behavior: 99010600 gets displayed
    Actual behavior: field is empty

    Setup:

    Safari Version 11.1.2
    SmartClient Version: v12.0p_2019-04-03/PowerEdition Deployment (built 2019-04-03)

    Thanks in advance,
    Kind Regards

  • #2
    It seems like you are expecting the implicit criteria to be displayed as the current value in the comboBox. That's not what this property does - the criteria are implicit, that is, not shown to the user. They just affect what is shown in the pickList.

    If you meant something else, like a difference between Safari MacOS and other browsers, please be specific as to what you are seeing in other browsers that you wanted to happen here.

    Comment


    • #3
      Sorry for beeing unclear. It has nothing to do with implicit criteria. I think the problem is the disabled dynamic form.

      The main issue here is, that the SKU in the cbi is shown in chrome and other browsers but not in safari on mac.

      Comment


      • #4
        After some investigation, we believe this is a browser bug affecting cases where "background-color: transparent" is used in Safari. We only see it for the Enterprise-series skins, and not for the new Tahoe skin. Did you observe this with Enterprise skin? Note that the text will be greyed, so more difficult to see than normal, but clearly it shouldn't be invisible.

        We're applying a fix to our CSS which should be in the nightly builds dated 2019-04-09 and beyond.

        Comment


        • #5
          We observed that behavior with the Enterprise- and the Tahoe-skin. The applied fixes worked for us after spending hours of investigation, because we thought the changes only apply to Enterprise, as You said. Some more information about the fix would have been very helpful, but at least it works now!

          Comment


          • #6
            We never reproduced this for Tahoe skin, only for Enterprise, so you had all the information we had. We have no idea what your hours of investigation entailed, but, there was nothing we could have done that would have helped you avoid it.

            Comment

            Working...
            X