No announcement yet.
  • Filter
  • Time
Clear All
new posts

    Smartgwt RichTextItem not visible

    Hello, we need to add RichTextItem inside DynamicForm, and it's added but compiled code doesnt provide field, just blank.gif like in image, we are using smartgwt 5.0-p20180625, GWT 2.7. Can you please help me out here is code and screenshot..? If you need any other information, please feel free to ask.

    RichTextItem richTextItem = new RichTextItem("description", "Description");
    Click image for larger version  Name:	Pagee.jpg Views:	1 Size:	116.1 KB ID:	258626
    Last edited by celebija.redzic; 10th Jul 2019, 00:29.

    What are your results from the basic procedure before posting an issue: Developer Console warnings or errors, trying multiple browsers, trying the Showcase sample to verify that your machine is working normally?


      Yea, there is no warnings or errors in Developer Console, also tried with Chrome, Mozilla and IE, same output. and yea about Showcase I checked and it looks fine. There is also screenshot from showcase..

      I tried directly using RichTextEditor and getting this error message in dev console (hope it can be helpful):
      Attached Files
      Last edited by celebija.redzic; 12th Jul 2019, 04:27.


        Your results appear impossible - either there’s an error or something should be showing.

        It looks like you are probably trying this in your app, not standalone. You may have error handling which is smothering our error reporting, so try standalone.

        Also please explain what you mean by “trying to use RichTextitem” directly. The error you posted seems to require directly using SmartClient (not SmartGWT) code and using it invalidly as well.


          Still we didn't found solution for this problem, and need this component ASAP.. Can you give me please what should I check, do I miss some kind of plugin. Or whatever..?? Is there any other solution I can use? come on some support...


            Have you loaded the ISC RichTextEditor module, along with the other ISC modules?
            Last edited by Isomorphic; 6th Aug 2019, 05:50.


              Yes, somehow looks like that was a problem :P thank you. now it is fine..