No announcement yet.
  • Filter
  • Time
Clear All
new posts

    Error With Smartgwt Builtinds Archetype Example

    Hello, Isomorphic:

    I've been trying to install the BuiltIn Ds project v4.1 or v6.1, using different approaches. I had some troubles which I tried to solve by checking other people's posts or applying the steps you recommended me. In summary your recommendation was using the most resent version of SmartGWT (since my licensed version is too old... :().

    In order to evaluate if I can migrate to a most recent version of SGWT, I created a project using SmartGWT v13.0, so I followed the instructions from the Maven Support page, like this:

    1. I installed some SmartGWT jars in my Maven repository:
    mvn install:install-file -DgroupId=com.isomorphic.smartgwt.eval -DartifactId=smartgwt-eval -Dversion=13.0-p20220718 -Dpackaging=jar -DgeneratePom=true -Dfile=smartgwtee.jar
    mvn install:install-file -DgroupId=com.isomorphic.smartgwt.eval -DartifactId=isomorphic-tools -Dversion=13.0-p20220718 -Dpackaging=jar -DgeneratePom=true -Dfile=isomorphic_tools.jar
    mvn install:install-file -DgroupId=com.isomorphic.smartgwt.eval -DartifactId=isomorphic-sql -Dversion=13.0-p20220718 -Dpackaging=jar -DgeneratePom=true -Dfile=isomorphic_sql.jar
    mvn install:install-file -DgroupId=com.isomorphic.smartgwt.eval -DartifactId=isomorphic-core-rpc -Dversion=13.0-p20220718 -Dpackaging=jar -DgeneratePom=true -Dfile=isomorphic_core_rpc.jar
    2. In a CMD, I changed to "..\smartgwtee-13.0p\maven\archetypes" directory and I installed the archetypes for archetype-smartgwt-example-builtinds:
    mvn install:install-file -Dfile=archetype-smartgwt-example-builtinds.jar -DgroupId=com.isomorphic.archetype -DartifactId=archetype-smartgwt-example-builtinds -Dversion=13.0-p20220718 -Dpackaging=jar -DgeneratePom=true
    3. I used that archetype to generate my app:
    mvn archetype:generate -DartifactId=built-in-ds13 -Dmodule=BuiltInDs13 -Dmodule-short-name=builtinds13 -DgroupId=com.domain-Dpackage=com.domain.builtinds13 -DarchetypeGroupId=com.isomorphic.archetype -DarchetypeArtifactId=archetype-smartgwt-example-builtinds -DarchetypeVersion=13.0-p20220718 -DinteractiveMode=false
    4. After checking the instructions in README File, I imported the created project in Eclipse; but after update dependencies I got two errors that I couldn't solve:
    • In datasource.jsp and index.jsp files from builtindsmvn-server project: Can not find the tag library descriptor for ""
    • In pom.xml file from builtindsmvn-server project: Could not initialize class org.apache.maven.plugin.war.util.WebappStructureSerializer

    I really appreciate if you could help me with some instructions to solve these errors

    I'm working with:
    SmartGWT 13.0 Eval (13.0-p20220718)
    Apache Maven 3.8.6
    JDK 1.8.0_241
    GWT Libraries 2.8.1
    Eclipse 2022-06 (4.24.0)

    Thanks in advance for you help!

    The steps you've taken here are not what's found on the "Maven Support page" you've linked to. The easiest thing for you to do is to delete your project and whatever artifacts you installed to your repo and try again, this time using only the documented commands.


      Hi, Isomorphic:

      You were right, I followed the three basic steps described on the MavenSupport page and, then, the instructions in the README file and I ran the BuiltInDs project successfully.

      Thank you very much for your valuable help!