Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

    Few smartGWT controls are not working in "Project Spartan" browser.

    Hi Isomorphic,

    Thank you for your support.

    I am using Smart Gwt-4.1p (29th Oct 2014)
    Browser: Google chrome 39.0.2171.95 m, IE8 and IE9

    During evaluation of my application in "Project Spartan browser"(which is deployed in Window 10 Tech preview), I found that following smartGWT controls are not working properly.

    issues:
    1. Tooltips and validation(Error) messages are not displayed.
    Issue:
    Tooltips and validation messages are not displayed in "Spartan" browser.Please find the attached screen shots for your reference.
    File Name:
    ToolTipAndValidations.jpg
    Showcase URL:
    http://www.smartclient.com/smartgwt/...orm_type_reuse
    http://www.smartclient.com/smartgwt/...raction_hovers


    2. Treegrid not opened by giving single click.
    Showcase URL: http://www.smartclient.com/smartgwt/...ured_tree_grid.


    3. Column menu icon is not displayed.
    Issue:
    column menu icon is not displayed in "Spartan" browser.Please find the attached screen shots for your reference.
    File Name:
    IconNotDisplayed.jpg
    Showcase URL:
    http://www.smartclient.com/smartgwt/...form_grid_item

    Please let us know whether SMARTGWT have any plans to provide support for “Spartan browser” in further.

    Regards,
    Attached Files
    Last edited by vnathank; 27th Apr 2015, 04:26.

    #2
    The "Spartan" browser currently breaks on a lot of basic content. We will revisit it when it's more stable.

    Comment


      #3
      Support for Microsoft Edge browser

      Hi,

      Is there any update on SmartGWT support for Edge browser of Windows 10 ?

      Thank you.

      Comment


        #4
        We've applied a few changes required to correct basic breakage (which came from Edge impersonating every other major browser engine in it's user agent string).

        Currently we're accepting bug reports only against 5.0+.

        It's unclear so far which versions of SmartGWT will have official support (as in the guarantee to fix any bug). We have to see how many serious browser bugs are identified as larger applications are comprehensively tested with Edge.

        Comment


          #5
          Hi,
          Is there any update on Edge browser support ? We would like to know whether any SmartGWT library release is planned for Edge support ?
          Thank you.

          Comment


            #6
            It looks like you may not have read the previous post from Isomorphic. Please take a look.

            Comment


              #7
              I read your 5th Aug 2015, 02:40 reply already. I would like to know whether any updates further or any plan for next release.
              So that, we can purchase that version of SmartGWT library.

              Comment


                #8
                There would be no point in upgrading to anything less than 5.0.

                Comment


                  #9
                  Hi,
                  Our intention is to know when is the next official release of 5.x version with Edge browser support from SmartGWT.
                  As you explained on "5th Aug 2015, 02:40", We are expecting the updates in version 5.0 & not less than 5.0.
                  Kindly let us know if any information is available for SmartGWT 5.x updated for Edge browser support release.
                  Thank you.

                  Comment


                    #10
                    It's very strange, you keep asking an already-answered question. So again:
                    We've applied a few changes required to correct basic breakage (which came from Edge impersonating every other major browser engine in it's user agent string).

                    Currently we're accepting bug reports only against 5.0+.
                    So to state it all again: Edge is generally working with 5.0. 5.0 is the version you should use if you want Edge support. We are accepting bug reports for problems with Edge that occur with 5.0.

                    Comment


                      #11
                      Our expectation of your reply was based on your below sentence.

                      "It's unclear so far which versions of SmartGWT will have official support (as in the guarantee to fix any bug). We have to see how many serious browser bugs are identified as larger applications are comprehensively tested with Edge."

                      Thanks for the support.

                      Comment


                        #12
                        That sentence remains true. The process of figuring out whether a browser is really supportable in an older version of SmartClient takes a while; things can appear superficially fine, then we may find out about a memory leak or intermittent crash that will take a great deal of effort to work around, meaning real support will only be available in the very latest version.

                        This actually happened with IE9, which leaks memory during basic, pervasively used JavaScript operations (eval()). It initially looked supportable in older versions, then we had to limit support to the latest version only, because extensive changes were required to work around IE9's bugs.

                        However the main point is that the process of figuring out whether older versions might support Edge doesn't matter to you. If you want Edge support, update to the latest - nothing else needs to be considered.

                        Comment

                        Working...
                        X