Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • 11.1p/12.0d: Calendar time format in German locale wrong

    Hi Isomorphic,

    please see this sample (v11.1p_2018-03-10) and all other Calendar samples.
    The default time format in German is e.g. "01:00nachmittags", but it should read "13:00".

    Best regards
    Blama

  • #2
    Actually, this applies everywhere in Calendar/Timeline, e.g. also when editing an calendar event:
    Click image for larger version

Name:	Event editing.PNG
Views:	1
Size:	26.6 KB
ID:	252189

    Best regards
    Blama

    Comment


    • #3
      The AM/PM strings are settable in the locales:

      Code:
          time_AMIndicator: 'vormittags',
          time_PMIndicator: 'nachmittags',
      To prevent those being shown, you can set calendar.timeFormatter.

      Comment


      • #4
        Hi Isomorphic,

        I'd think that this should be handled in the framework automatically.
        Thinking about it, I wonder why in e.g. this sample the time controls in English locale don't use am/pm, but hours 0-23.

        Best regards
        Blama

        Comment


        • #5
          Globally, times have always been formatted (by default) in 12-hour format - you don't see this in TimeItems because they have a use24HourTime attribute which defaults to true.

          We've made a few changes here - there is now a global setting, isc.Time.use24HourTime, which appears in the language packs and defaults to true.

          As of builds of 12.0 dated March 16, setting this will alter both TimeItems and all aspects of Calendars accordingly - setting TimeItem.use24HourTime or Calendar.twentyFourHourTime locally overrides the global value.

          Comment


          • #6
            Hi Isomorphic,

            thanks a lot. I think its a good change and can see it working here (SNAPSHOT_v12.0d_2018-03-17).

            While I get the setting for this in getlocalization.com (time_use24HourTime), I think an explanation in the docs for this might be valuable, because it's the first time I've seen a setting in the localization (and of course I should not translate it to "Wahr", but set it to either "true" or "false").

            Best regards
            Blama

            Comment

            Working...
            X