Hi Isomorphic,
after your blog entry I tested the new requiredCriterion sample.
I think this is another good feature w.r.t to security, as I assume one could enforce "1-row fetches allowed only" with
which would translate to a allowMultiFetch="false" (analogue to allowMultiUpdate), if such an attribute existed. Is this correct?
As an improvement suggestion:
Right now (SNAPSHOT_v12.1d_2019-02-03) you return "Operation requires criteria for the following field(s): [area, population]" which is not localized, see e.g. here in German.
As this is supposed to be a GUI feature, too, and not only a security feature (my assumption), it would be good if the message would be localized and if you returned the field title instead of the field name. name -> title is clear here, but this might not always be the case.
If it is not meant to be a GUI feature, but only a security one, this does not apply. But then a shorthand for the primaryKey-field like the suggested allowMultiFetch="false" would be nice as well.
Best regards
Blama
after your blog entry I tested the new requiredCriterion sample.
I think this is another good feature w.r.t to security, as I assume one could enforce "1-row fetches allowed only" with
Code:
<field name="id" primaryKey="true"> <validOperators> <operator>equals</operator> </validOperators> <field> ... <operationBindings> <operationBinding operationType="fetch" operationId="fetchByRequiredCriterion" requiredCriterion="id" /> </operationBindings>
As an improvement suggestion:
Right now (SNAPSHOT_v12.1d_2019-02-03) you return "Operation requires criteria for the following field(s): [area, population]" which is not localized, see e.g. here in German.
As this is supposed to be a GUI feature, too, and not only a security feature (my assumption), it would be good if the message would be localized and if you returned the field title instead of the field name. name -> title is clear here, but this might not always be the case.
If it is not meant to be a GUI feature, but only a security one, this does not apply. But then a shorthand for the primaryKey-field like the suggested allowMultiFetch="false" would be nice as well.
Best regards
Blama
Comment