Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

  • Transport Error - HTTP Code: 0

    Hi,

    My SmartClient version: v90p_2013-09-20_LGPL
    I'm getting a Transport Error, with HTTP Code 0, in all browsers. There is an Ajax request to the server, that responses a JSON. Sometimes the request runs normally, but after this, I get the error.
    Logging the response of the server at the console, I get:

    Code:
    response: Object
    data: "Transport error - HTTP code: 0 for URL: my_php_file.php"
    status: -90
    and a PUT (HTTP request) error.
    I looked the server-side code searching for problems, but I couldn't find anything. The JSON is sent normally.
    I also tried to up the timeout of the Ajax request, but it doesn't solve the problem.

    The server logs: "(104)Connection reset by peer: client stopped connection before rvputs completed"

    Thanks!
    Last edited by ueng; 7th Oct 2013, 12:42.

  • #2
    There's a well-known bug of this kind in IE, but the only time we've seen this reported across multiple browsers, it was an attempt to do a cross-domain request.

    Note that the browser may consider your request to be cross-domain just because the URL starts with "http", even if it's actually to the same host. If your url starts with http, make it a relative URL to fix the issue.

    Comment


    • #3
      Looking again the code, and the request made, it's already a relative URL.
      I'm using "isc.RPCManager.sendRequest", doing a PUT. The server-side makes a database update and returns a JSON with the response (even we get an error). This error occurs when we do this update for the first time. If we already updated an item (with error or not), and update it again, this error does not occur. The server-side code executes normally, but it doesn't response correctly. Some searches that I did said that this kind of error occurs when some of the sides (client or server) interrupt the connection.
      There is another weird thing: at Firefox, we can do this requests for many times, until the error comes. At Chrome and IE10, this error can come for the first time, or at a second or third.

      Comment


      • #4
        This isn't one we've seen before, nor do people seem to be reporting a similar issues reported in online forums.

        It appears to be something happening at the network layer and this out of the control of both the browser and server parts of SmartClient.

        What we'd suggest is to first try a different network environment - one without any proxies, security products installed on the webserver, firewalls or anything else between browser and server. If the problem doesn't occur there, reintroduce each of the above intervening systems one by one to isolate the cause.

        Comment


        • #5
          Click image for larger version

Name:	image_12146.png
Views:	2
Size:	11.4 KB
ID:	258106 Hi please i have the same error message and i can't understand the source of the problem, I need your help.
          the error is aparait without doing any action but only after a certain time.

          Comment

          Working...
          X