Just a quick follow-up on this thread.

I did find a post we made quite some time ago where there was a batik dependency for chrome and ff....