No announcement yet.
  • Filter
  • Time
Clear All
new posts

    Unknown javadoc format

    Hi tried to add the javadoc to isomorphic_core_rpc.jar in the classpath

    <classpathentry kind="var" path="SGWTEE_HOME/lib/isomorphic_core_rpc.jar">
    <attribute name="javadoc_location" value="file:/D:/Projects/smartgwt/smartgwtee-12.0p/doc/server/javadoc/"/>

    Eclipse is unable to show its content and throws an exception:

    java.vendor=Oracle Corporation
    BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=nl_NL
    Framework arguments: -product org.eclipse.epp.package.jee.product
    Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product

    Mon Aug 26 15:12:40 CEST 2019
    Unknown javadoc format for RPCManager(javax.servlet.http.HttpServletRequest, javax.servlet.http.HttpServletResponse) {key=Lcom/isomorphic/rpc/RPCManager;.(Ljavax/servlet/http/HttpServletRequest;Ljavax/servlet/http/HttpServletResponse;)V|Ljava/lang/Exception;} [in RPCManager [in RPCManager.class [in com.isomorphic.rpc [in D:\Projects\smartgwt\smartgwtee-12.0p\lib\isomorphic_core_rpc.jar]]]]

    Although this is really an eclipse question, I too am struggling with how to see isomorphic documentation w/ the eclipse. An example of how to would be great!


      We're actually getting the same error, and the online suggestions we're seeing do not resolve it.

      Best guess is that it's not working because we have slightly customized the JavaDoc generation to avoid showing public methods which have no docs (because trying these two concepts together in JavaDoc is frankly completely boneheaded, forcing to you choose between exposing methods that have no docs, or lots of busywork to plumb access needed across related packages).

      We would recommend using a third-party JavaDoc viewer that isn't so fragile. If you find a good one, we'd love to know.

      Note: there's also Google, plus site-specific search.



        note: I saw a request for bug reports (eclipse 2022-12) that mentioned known javadoc issues exist. I don't know if it is the same as what this thread is experiencing yet though. This issue existed for me in 2022-06 in previous versions as well.

        Work around:
        With regards to the eclipse javadoc view. I found that when you click on a symbol, such as Logger (com.isomorphic.log.Logger) , I found out that even though the view's window says "An exception occured while getting the Javadoc..." , you can right click in the view and choose open attached javadoc. It then opens an external file browser to the correct documentation directory. You can then drag the appropriate htm file (Logger.html) into the Javadoc view and see the documentation as intended.

        My class path is configured as such, Where SGWTPOWER_HOME is a class path variable configured to the install base of the smartgwtpower-13.o library's directory:

        <classpathentry kind="var" path="SGWTPOWER_HOME/lib/isomorphic_core_rpc.jar">
        <attribute name="javadoc_location" value="file:SGWTPOWER_HOME/doc/server/javadoc"/>

        > We would recommend using a third-party JavaDoc viewer that isn't so fragile. If you find a good one, we'd love to know.
        The "javadoc search frame" chrome plugin works great to search/organize with your online client and server javadoc URLS ( & )


          Hey Eric, just wanted to say thanks very much for posting your workarounds.

          We also have a guess at what is making Eclipse reject our Javadoc, and if we can get the time, we’ll test it out (it will involve modifying our JavaDoc output).


            Hi Isomorphic,

            I reported a related or the same issue a few years back here:

            Best regards


              P.S. The exception Blama points out in his linked report is the same one I am seeing. Thanks Blama for pointing out where the log file is that the pop up was referencing :)