Announcement

Collapse
No announcement yet.
X
  • Filter
  • Time
Clear All
new posts

    Issues with right-clicking on cube grids to hide column facets

    Hello,

    When I right click on the STA Rundir column in my cube grid, I see options to hide the column facets. This is good and the intended behavior. See here:

    Click image for larger version  Name:	ss_1.png Views:	0 Size:	47.1 KB ID:	259971

    However, when I right-click on the PV Rundir facet or the one below that, I see only one option grayed out. This does not allow me to hide the facets. See here:

    Click image for larger version  Name:	ss_2.png Views:	0 Size:	34.6 KB ID:	259972

    Could you please fix this? It is difficult for some users to hide facets with right-click since there is only one option which is grayed-out.
    Last edited by user316; 11th Nov 2019, 06:34.

    #2
    It's not 100% clear from your screengrab, but it appears as if there might only be one facetValue for your two innermost column facets (so including "PV Rundir") per parent facetValue. That's based on the facetValues for column facet "STA Rundir" only spanning one facetValue of next more inner facet. Take a look at the Basic Cube Sample to see our point. There, you can clearly see that, for example, "January" spans two facetValues of the next more inner facet.

    If true, then what you're seeing is expected behavior, since that context menu isn't designed to let you hide the last facetValue under a parent facetValue, leaving no facetValues

    Comment

    Working...
    X